locked
"Written accent " problems in Expression Web 3 RRS feed

  • Question

  • Hi, Im having a lot of problems with written accents in expression web 3. Im spanish and I need this to work. I didnt have any of this problems with expression web 2. I always code my HTMLs in UTF-8. When I wan to put a word like qué EW3 puts a strange symbol. What could I do?

    Example with Expression Web 2:
    Example EW2

    Example with Expression Web 3:
    Example EW3
    Monday, October 19, 2009 5:34 PM

Answers

  • You are right, I picked the wrong one. This is the bug I was referring to. They "will be looking at this for Expression Web 4". Believe me, I am not happy with this delay either.
    Tuesday, October 20, 2009 11:32 AM

All replies

  • What happens if you enter it using Alt+0233  é
    Expression Web MVP
    Monday, October 19, 2009 6:19 PM
  • This is a known bug in xWeb 3. A viable workaround might be to run %windir%\system32\charmap.exe and copy the desired characters to xWeb.
    Tuesday, October 20, 2009 9:57 AM
  • This is a known bug in xWeb 3. A viable workaround might be to run %windir%\system32\charmap.exe and copy the desired characters to xWeb.

    This is a "botched job". Impresionant solution. Microsoft dont think solve this?
    Tuesday, October 20, 2009 10:26 AM
  • What happens if you enter it using Alt+0233  é
    Expression Web MVP

    This works, if I press ALT+0233 in numPad EW writes é, but I think that Expression Web itsnt usable for Spanish users for now.

    Tuesday, October 20, 2009 10:29 AM
  • This is a known bug in xWeb 3. A viable workaround might be to run %windir%\system32\charmap.exe and copy the desired characters to xWeb.

    Im not referring to this bug. This is other bug that happens in UTF-8 and any other coding.
    Tuesday, October 20, 2009 10:34 AM
  • You are right, I picked the wrong one. This is the bug I was referring to. They "will be looking at this for Expression Web 4". Believe me, I am not happy with this delay either.
    Tuesday, October 20, 2009 11:32 AM
  • Hi, it's incredible that Microfot released E3 only for English content.... even if the product is translated to Spanish and all other languages. The only workaround I've found is using traditional HTML tagging for accents and other signs: ó é and so on.

    Copy and paste áéíóú also works
    • Proposed as answer by dpiret Thursday, October 22, 2009 1:34 PM
    Thursday, October 22, 2009 1:34 PM
  • Disgraceful , expression web 3 goes back.
    Thursday, October 22, 2009 4:17 PM
  • Fine. Seeya. Maybe come back after you've spent four or five times as much for Dreamweaver and tell us how disappointed you are to learn that it has warts, too. Ta ta...

    scott

    Plural's don't have apostrophe's. It seem's sometime's that any word's ending in "s" get a gratuitous apostrophe. Apostrophe's are used to indicate possessive's and elision's (contraction's or abbreviation's).
    Thursday, October 22, 2009 4:37 PM
  • Thanks for pointing this critical bug. I use foreign characters daily in my English language sites and was planning to upgrade from EW2 to EW3 after SP1 fixes the select text bug and allows users to change the unreadable black background interface. The inability to enter foreign characters routinely with Windows' United States-International keyboard renders EW3 useless to me. So I will have to wait at least another year or two to be able to select text to the left border without selecting the whole page or to change a DWT on multiple pages at once.
    Sunday, October 25, 2009 3:29 PM
  • I was with this same problem and managed to solve it of the following way:

    1) Search the file "user.config" in your computer. Probably you will find 4.
    2) One of these files (and it is what interests) is in some user's folder. In my computer it is in C/Documents and Settings/my name/AppData/Microsoft/Expression/Web3/user.config.
    3) Open this file with Notepad.
    4) Search for the lines
    <PrimitiveObject Name="Visibility" Type="System.Windows.Visibility">Visible</PrimitiveObject>
    <PrimitiveObject Name="Visibility" Type="System.Windows.Visibility">Collapsed</PrimitiveObject>
    There are 11 of these lines.

    Except for the first of these lines [ that in the tag <ConfigurationObject>  where appears Type="System.Int32">0< ], all the other should have the characteristic Collapsed, and not Visible.

    If in some of them appear the Visible characteristic, replace for Collapsed and save the file.
    This solved my problem and hope that it solves yours.
    PS.:  If the problem reappear, repeat the procedure. Or then copies the file corrected for another folder and substitute it when necessary.

    [ ]'s
    Alberto Mesquita Filho

    Saturday, November 7, 2009 9:08 AM
  • Someone has tried this solution?
    I cant because I have uninstalled Expression Web 3
    Thursday, November 12, 2009 4:52 PM
  • Well, given his post, it's almost a certainty that Alberto has tried it. What do you want, sworn testimony from multiple testers? Those of us with no need for foreign language diacriticals don't have the problem, so since you do, if I may suggest, you might want to give Alberto's method a shot. Seems to have worked for him...

    cheers,
    scott
    Plural's don't have apostrophe's. It seem's sometime's that any word's ending in "s" get a gratuitous apostrophe. Apostrophe's are used to indicate possessive's and elision's (contraction's or abbreviation's).
    Thursday, November 12, 2009 5:16 PM
  • "It would be nice if EW3 could leverage Word's spelling tools better."

    Kinda unlikely, considering that MS is doing everything it can to eliminate all vestige of connection to Office from EW. AFAIK, the Word spell checker is not used in EW3, and probably will never be again.

    BTW, I haven't tested for accented character preservation, but I believe you can save yourself an intermediary step if you paste directly from Word into EW, only instead of using Paste or Ctrl-V, select "Edit|Paste Text" and select "normal paragraphs with line breaks." That strips all the Word gunk formatting and will probably preserve the accented characters for you. Give it a try and let us know how it goes.

    cheers,
    scott
    Plural's don't have apostrophe's. It seem's sometime's that any word's ending in "s" get a gratuitous apostrophe. Apostrophe's are used to indicate possessive's and elision's (contraction's or abbreviation's).
    Friday, November 13, 2009 11:39 PM
  • Hi,
    I've tried Alberto's solution without success. In my case, the user.config file has every 'visibility' line with 'Collapsed' characteristic execpt the first one, just as Alberto said. And the problem remains.
    Regards,

    Carlos,
    Friday, February 5, 2010 12:06 PM
  • I have no problem with accents. I use the US-International Keyboard

    see http://dmreed.com/us-international_kb_overview.html

    I also use <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    and I have no problems using "á, é, í, ó ú, ñ, ü". The previous quoted letters all have accents on my display.

    Saturday, May 8, 2010 10:44 AM
  • Hi evryone,

    While I'm hoping and waiting for version 4.o to correct this bug I'm using 'code snippets' to paste my french characters in code view.

    I've posted a procedure to install all french characters in the code snippets :
    http://paradisj.blogspot.com/2010/06/keyboard-problem-with-language-other.html


    Jean-Pierre Paradis
    Thursday, June 3, 2010 12:28 AM
  • Better would be a SP for this version instead of yet another version to buy every year or so.

    Since version 4 is a free upgrade from version 3, I'm afraid I don't see your point.

    Paul Bartholomew, Microsoft Expression Web

    Thursday, June 3, 2010 1:32 AM
    Moderator
  • Jean-Pierre,

    You could create a new Snippet collection for the French characters and put it on the Expression Gallery.

    http://gallery.expression.microsoft.com/en-us/site/search?f[0].Type=RootCategory&f[0].Value=scripts&f[0].Text=Code%20Snippets

    Ian
    MS MVP Expression

    http://www.ew-resource.co.uk


    Ian Haynes
    Thursday, June 3, 2010 11:01 AM
  • For me, adding "<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />" in the head has solved the problem.

    I've EW since a long time, up to date (MSDN subscripter as I'm a MVP) and this problem was annoying me since the begining (I'm French and they are a lot of words with accents). It was so annoying that I was using DreamWeaver instead of EW !

    Using the simple meta tag solved this problem and I can now enjoy EW (and have uninstalled Dreamweaver :-) )


    Olivier Dahan Dot.Blog : www.e-naxos.com/blog
    Wednesday, June 29, 2011 4:26 PM
  • Vegan, this thread is about use of EW by those who write and compose in accented languages, not about needing the occasional symbol. Character Map is as useless to them as memorizing the full set of escape codes (which I suspect was meant to mean "character entities") or ANSI Alt-#### equivalents.

    But then, non sequitur posts are pretty much the norm for you, aren't they?

     


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Wednesday, June 29, 2011 5:50 PM