locked
Unable to receive ServiceBus Queue Messages RRS feed

  • Question

  • Hi,

    we're using several queue's to distribute write operations to our database over time.

    One queue gives us the trouble, that we can't receive message from it.

    Apparently new messages get written to it (size and message count grows) but receiving a message results in the error 'No messages to receive' (using node.js)

    Using the Service Bus Explorer results in similar results, message count and everything else is shown. No dead letter message, all messages as active. Peeking or receiving results in nothing.

    Any clue how to solve this?

    Cheers

    Tuesday, May 7, 2013 3:30 PM

All replies

  • In Service Bus 1.0, there was an error in reporting the size of dead letter queue (API returning 0).

    My guess is that you have the messages just waiting for you in the DLQ. Try running a program which read from your DLQ (like this sample: http://code.msdn.microsoft.com/Brokered-Messaging-Dead-22536dd8 )

    regards,

    Ziv , Windows Azure Service Bus team

    Wednesday, May 8, 2013 9:24 PM
  • thanks for the reply, though the service bus explorer only shows active messages.

    Active Message Count 22771

    DeadLetter Message Count 0

    Any other ideas? At the moment I do not believe it is anything wrong on our end, as all other queues are running just fine using the same code base on our side.

    Wednesday, May 8, 2013 11:20 PM
  • just as a side node: another queue shows sometimes negative size values, as well as a negative message count.

    Saturday, May 11, 2013 12:28 AM