locked
Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server 'abc.xyz.com'. RRS feed

  • Question

  • User542092914 posted

    Hi,

    We are getting this error in every 6-8 hours on our Web farm, application and platform provisioning both has been disabled.

    Failed to run operation 'RunRemote'.  Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server 'abc.xyz.com'.  Remote agent (URL http://abc.xyz.com:8173/WEBFARMAGENTSERVICE/) could not be contacted.  Make sure the remote agent service is installed and started on the target computer.  Unable to connect to the remote server.  No connection could be made because the target machine actively refused it x.x.x.x:8173.  Remote agent (URL http://abc.xyz.com:8173/WEBFARMAGENTSERVICE/) could not be contacted.  Make sure the remote agent service is installed and started on the target computer.  Unable to connect to the remote server.  No connection could be made because the target machine actively refused it x.x.x.x:8173.

    I have checked the Apphost.config , application and platform provisioning are in disabled in config as well. I don't why we are getting this error. Please find the below apphost config entry

    <webFarm name="name" enabled="true" adminUserName="username" adminPassword="somepassword" primaryServer="primaryservername">
    <server address="primaryservername" enabled="true" />
    <server address="secondaryservername" enabled="true" />
    <platformProvision stopOnInstall="false" periodicSync="00:05:00" syncPlatformFromPrimary="false" />
    <applicationProvision offlineWhileSync="false" syncWebServerFromPrimary="false" periodicSync="00:00:30">
    <clear />
    </applicationProvision>
    <applicationRequestRouting>
    <affinity useCookie="false" ignoreSubDomainClientAffinity="true" />
    <loadBalancing algorithm="LeastRequests" />
    <healthCheck url="healthcheckurl" interval="00:00:30" timeout="00:00:30" responseMatch="Page Successfully Loaded" />
    <protocol timeout="00:01:00" />
    </applicationRequestRouting>
    </webFarm>

    Monday, May 2, 2016 7:55 AM

All replies

  • User1278090636 posted

    Hi,

    Have you checked your firewall? Perhaps it is blocked by your firewall.

    Best Regards,

    Jean

    Tuesday, May 3, 2016 5:47 AM
  • User542092914 posted

    Yes, we have checked the firewall, firewall are in disabled mode for all the servers.  

    Tuesday, May 3, 2016 5:55 AM
  • User542092914 posted

    Hi,

    Have you checked your firewall? Perhaps it is blocked by your firewall.

    Best Regards,

    Jean

    Yes, we have checked the firewall, firewall are in disabled mode for all the servers.  

    Tuesday, May 3, 2016 5:57 AM
  • User1278090636 posted

    Hi,

    This error should be related to network settings.

    Perhaps the network is not stable. So this error occur every 6-8 hours.

    Best Regards,

    Jean

    Tuesday, May 10, 2016 7:40 AM