locked
Target framework vs2010 RRS feed

  • Question

  • Hi,

     

     I have got VS2008 and VS2010 installed on the same machine and still when I try to change the target framework for a project in VS2010 it asks me to install other frameworks. Why cant it see the .NET 3.5 framework, any ideas as to what I have done wrong.

     

    Thanks

    Wednesday, July 7, 2010 9:45 AM

Answers

  • Hi Tribal,

    Thank you for your post.

    To target other .NET Framework like .NET 2.0, 3.0 and 3.5 in Visual Studio 2010, we need have these .NET Frameworks installed and upgrade .NET Framework 3.5 to SP1 on the machine.
    For more information on Multi-Targeting feature, please visit: http://msdn.microsoft.com/en-us/library/bb398197.aspx

    Please try to upgrade .NET Framework 3.5 to SP1 by download .NET Framework 3.5 Service Pack 1 or Visual Studio 2008 SP1 which will upgrade both .NET Framework 3.5 and Visual Studio 2008 to SP1.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by tribal Thursday, July 8, 2010 2:36 PM
    Thursday, July 8, 2010 10:52 AM

All replies

  • What Windows version/edition?

    Which VS did you install first?

    If you don't get more elegant suggestions, a repair install of VS 2010 is a brute force possibility.

    Wednesday, July 7, 2010 1:24 PM
  •  

    Win XP Professional version 2002 SP3, I installed VS2008 first and then VS2010. Is this the right forum for this question though

     

    Thanks

    Wednesday, July 7, 2010 3:55 PM
  • I think you're in the right forum.

    Hopefully, somebody else will offer useful suggestions less crude than a repair install.

     

    Wednesday, July 7, 2010 5:39 PM
  • Hi Tribal,

    Thank you for your post.

    To target other .NET Framework like .NET 2.0, 3.0 and 3.5 in Visual Studio 2010, we need have these .NET Frameworks installed and upgrade .NET Framework 3.5 to SP1 on the machine.
    For more information on Multi-Targeting feature, please visit: http://msdn.microsoft.com/en-us/library/bb398197.aspx

    Please try to upgrade .NET Framework 3.5 to SP1 by download .NET Framework 3.5 Service Pack 1 or Visual Studio 2008 SP1 which will upgrade both .NET Framework 3.5 and Visual Studio 2008 to SP1.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by tribal Thursday, July 8, 2010 2:36 PM
    Thursday, July 8, 2010 10:52 AM
  •  

     Hi YiChun,

     

       Thanks for the reply, that worked like a charm. I installed .NET 3.5 sp1 and it seemed to solve the issue. I can now see the other Framework options in Visual Studio 2010.

     

     Regards

    Thursday, July 8, 2010 2:36 PM
  • Hi Tribal,

    It's my pleasure!

    I'm so glad to hear this good news!

    Have a nice experience of VS2010.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, July 9, 2010 7:05 AM