locked
Analysis Database Sync jobs will not automatically re-queue

    Question

  • See the attachment.

    The problem is, both, the Full and Incremental sync jobs run fine once, however they don't re-queue.  I've tried restarting the app server and stopping/starting the jobs.  When I stop and restart the jobs, the sync jobs are scheduled and run fine.  But, they don't automatically reschedule themselves to run again. 

    I'm having to constantly process them manually.

    If you notice in the attachment, my request to the process service is: 2013-02-16T23:29:54, however, the last time the Incremental ran was 2013-02-16T20:35:28.  There is no <NextRun /> element.  I've checked the settings, and its set to run every 7200 seconds (the 2-hour default).

    What's going on?

    Thanks.

    Saturday, February 16, 2013 11:40 PM

Answers

  • @ketelsb

    I too am running TFS 2012 Update 1.  This looks like a bug of some sort.  This issue started when I tried to process the Analysis server manually from the web administration service.

    I managed to get it automatically rescheduling though.  Here's what I did...

     

    1. Go to the TFS Console, Reporting page,  and click "Rebuild All"  (click yes, through the warnings of rebuilding the warehouse and analysis cubes.)  Since this was a new install with only a couple of project collections, it didn't take much time.
    2. Then go to the web service interface
      (http://<your url>:8080/tfs/TeamFoundation/Administration/v3.0/WarehouseControlService.asmx)
    3. Click "SetAnalysisJobEnabledState".  For state, type in: Enabled    Then, click Invoke. Even though the "GetSettings" said it was enabled, I wasn't convinced.
    4. Go back to the web service interface and Click "BringAnalysisProcessingOnline".  Click Invoke.

    Please let me know if this works for you.

    Wednesday, February 20, 2013 2:51 PM

All replies

  • Hi a11smiles,

    Thanks for your post!

    From a support perspective this is really beyond what we can do here in the forums. If you cannot determine your answer here or on your own, consider opening a support case with us. Visit this link to see the various support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 18, 2013 7:55 AM
    Moderator
  • I am using TFS 2012 Update 1

    I have exactly the same issue.

    I can trigger the ProcessAnalysisDatabase using http://localhost:8080/tfs/TeamFoundation/Administration/v3.0/WarehouseControlService.asmx.

    The Cube gets processed. But there is no reschedule.

    When I look at the Adminitrator Report "Cube Status", the Warehouse Data Age is correct, but the Analysis Data Age is way above 120 minutes.

    The only job that gets rescheduled is Optimize Databases.

    When I run the GetProcessingStatus with includeOnlineHostsOnly set to 'true', there are no errors and no jobs queued. 

    The Full Analysis Database Sync and Incremental Analysis Database Sync have no <NextRun> tag.

    Is there some way that I can trigger the NextRun for the jobs?


    ketelsb

    Wednesday, February 20, 2013 2:38 PM
  • @ketelsb

    I too am running TFS 2012 Update 1.  This looks like a bug of some sort.  This issue started when I tried to process the Analysis server manually from the web administration service.

    I managed to get it automatically rescheduling though.  Here's what I did...

     

    1. Go to the TFS Console, Reporting page,  and click "Rebuild All"  (click yes, through the warnings of rebuilding the warehouse and analysis cubes.)  Since this was a new install with only a couple of project collections, it didn't take much time.
    2. Then go to the web service interface
      (http://<your url>:8080/tfs/TeamFoundation/Administration/v3.0/WarehouseControlService.asmx)
    3. Click "SetAnalysisJobEnabledState".  For state, type in: Enabled    Then, click Invoke. Even though the "GetSettings" said it was enabled, I wasn't convinced.
    4. Go back to the web service interface and Click "BringAnalysisProcessingOnline".  Click Invoke.

    Please let me know if this works for you.

    Wednesday, February 20, 2013 2:51 PM
  • This seems to work.

    I set the EnabledState and brought the Processing back online.

    Now I see this in my report:

    Tomorrow morning I will see if they have been run and rescheduled.

    I'll keep you posted.


    ketelsb

    Wednesday, February 20, 2013 2:57 PM
  • Also,

    I added my TFS Service account to the Local Administrators group on both my SQL instance and my Reports server (the reports server is setup according to Microsoft's best practices - running the Reports and Analysis Services).

    The issue we are seeing may be a permissions issue somehow?

    Joshua

    Wednesday, February 20, 2013 3:01 PM
  • I can confirm that the jobs are rescheduled correctly now. Thanks.

    I would think that it is more a bug than a security issue.


    ketelsb

    Thursday, February 21, 2013 7:15 AM
  • I've written about this error on my blog.
    Monday, March 4, 2013 12:13 AM