none
Changes in .rdlc Not Displaying RRS feed

  • Question

  • I have an .rdlc report and made a field change on the dataside and updated the corresponding textbox on the report side.  However, the old .rdlc field is still displaying.

     

    I've updated and refreshed the data sources.  I've rebound my report viewer control.  I've checked the connection string to make sure I'm connecting properly.  When I preview the data in the dataset viewer, then the data field is correct.  When I run the report, the data is different. 

     

    Where else to I look to fix this?

     

    Thanks,

    cj

    Tuesday, June 12, 2007 4:24 PM

All replies

  • Hi there,

     

    I think this may have been a caching issue....if you go to the obj\Debug folder in your project...then you should see Project.ReportName.rdlc files.....delete these and try to rebuild & run the project...

    It may not be the solution in this case but it has worked for me.

     

    Tuesday, June 12, 2007 8:43 PM
  • Is the report an embedded resource or is it found by path?

     

    If it is embedded, make sure the ReportPath property is blank because -- if memory serves -- ReportPath is going to take precedence if both are filled out.  Also make sure that your buillt-in report resource is actually up-to-date.

     

    If it is external, check and make sure that ReportPath is what you think it should be -- put in some debugging code or whatever...

     

    >L<

    Wednesday, June 13, 2007 2:50 PM