none
Sleep and PNP automatically fails (Win Server 2008) RRS feed

  • Question

  • Since we cannot pass Sleep on PNP on a specific machine (hibernation disabled) we decided to use another machine. Now the problem is that Sleep and PNP automatically fails but unlike the previous case it stops in [Test in progress] and HCK seems to crash too on the client machine (the tests checkboxes are grayed). This happend on a Windows Server 2008 R2, the strange thing is the same test passes on a Windows 7 (even when using the same machine!). Any advice/suggestion will be appreciated.

    Wednesday, March 27, 2013 3:23 PM

All replies

  • Hi - I am seeing the same issue - have you gotten closer to a resolution on this?

    thanks

    lori

    Tuesday, April 2, 2013 9:01 PM
  • Hi HaryuMic,

    Please check the log and post the error here (also pick up few lines before and after the error, from log).

    Thanks,

    Nilesh.

    Wednesday, April 3, 2013 12:59 PM
  • Nilesh, I think I am seeing the same issue as HaryuMic (based on some other posts i've seen from them)

    the error I am getting is this each time it trys to do a hibernate

    Error 4/2/2013 3:59:34.929 PM WDTF_SYSTEM : To Hibernate the system with SetSuspendState(...) failed : 50 
    File:    Line: -1 
    Error Type:    
    Error Code:   0x0 
    Error Text:   Error 0x00000000 
    Message 4/2/2013 3:59:34.929 PM WDTF_SYSTEM : Returning from Hibernate. Elapsed time (hh:mm:ss): 0:0:2 
    Message 4/2/2013 3:59:34.929 PM WDTF_SUPPORT : - WaitForSeconds : 10 

    this is the last test I need to get past to be able to submit - it's for a FC SAN connected storage array.

    thanks

    Lori

    Wednesday, April 3, 2013 3:31 PM
  • So as a follow up - I tried to hibernate the server outside of the testing - the screen goes blank for about a second then it wakes up with the following cryptic error

    Insufficient system resources exist to complete the requested service.(1450)

    at this point I am at a loss as to how I am supposed to pass this test. Should I just submit as is with a note saying the test did not work

    thanks

    Wednesday, April 3, 2013 4:00 PM
  • So I got a little further - I ran a powercfg /a and it showed me that the graphics driver was not able to hibernate S1 - so I updated the generic microsoft driver to the one supplied by the server mfg (supermicro) - this enabled S1  - so parts of the test case are now working

    but hibernation state 4 still does not work

    this server has 48Gb RAM - is this the issue? it's also got no options in the BIOS to control S3 and S4 states .. this is a server board, so i did not really expect it to have those options - you don't typically sleep a server

    please advise

    Wednesday, April 3, 2013 5:52 PM
  • Lori, can you confirm which OS you are seeing this issue on?
    Wednesday, April 3, 2013 5:59 PM

  •  This is on Windows 2008 R2 SP1 I also downloaded the latest updates from microsoft



    This is a supermicro server with an intel motherboard with 48GB RAM - not atypical for a server today.

       I don’t think the test is valid on server class hardware… a typical server has more than 4GB of RAM – according to this KB http://support.microsoft.com/kb/888575?lc=1033 – You cannot put a computer that has more than 4 GB of memory into hibernation in Windows XP, in Windows Server 2003, in Windows Vista, or in Windows Server 2008. 



    I would argue that this is a valid case for workstations, but not for servers.

    Issuing a powercfg /a on the system I am testing with tells me that the system does not support more than S1 sleep states – there is no support in the BIOS for anything else – which makes sense as it’s a server class motherboard – servers don’t typically sleep

     Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\administrator.LOGOCERT>powercfg /a
    The following sleep states are available on this system: Standby ( S1 ) Hibernat
    e
    The following sleep states are not available on this system:
    Standby (S2)
            The system firmware does not support this standby state.
    Standby (S3)
            The system firmware does not support this standby state.
    Hybrid Sleep
    C:\Users\administrator.LOGOCERT>

    you will notice that the test case that fails only fails on the attempts at S4 sleep. the S1 sleep tests work ok , which validates the output from the powercfg command above.

    Thursday, April 4, 2013 3:46 PM
  • So I tried it with another supermicro with 12GB RAM - I am able to issue the command shutdown /h and it will hibernate - but the test case still fails with error 50 on S4 sleep - what is wrong with the test case?

    how do I get a waiver to pass this test?

    thanks

    Friday, April 5, 2013 2:31 AM