locked
Verify the Receive Location exists in IIS RRS feed

  • Question

  • Hello All,

    I never worked with webservices before and question can be very simple one. I am migrating the application from the DEV to TEST and in DEV the Receive Ports are webservices.

    I imported the MSI and bindings. And the Receive location is created. But I need verify the webservices exists in IIS. How can I do that.. As I said I never worked on the webservices not sure how it works.

    Tuesday, September 29, 2015 2:16 PM

Answers

  • Hi vdha,

    To verify your service exist and running on server please open service url on browser and press enter.

    If your service running properly then you will get screen like below,


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 2:31 PM
    Moderator
  • Did you host the service in the IIS from where you are pointing the BizTalk Receive location to?

    If it is "localhost" check the server IIS if the Service exist in the IIS and if it is pointing to some other server check that service. It should be up.

    Rahul

    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 2:33 PM
  • Hi,

    Have you verified IIS ? Is there any virtual directory created there for your receive location .

    Don,t get confused , If your MSI contains the virtual directory information (when you export the MSI look for the steps ,it will contain definition of IIS Virtual directory ),it will generate your VD on IIS after you completely run the msi .

    Thanks

    Abhishek

     
    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 4:35 PM
  • Hi vdha,

    Can you please verify the below?

    1. Visrual directory exists in IIS and application pool is created and started

    2. BizTalk receive location is enabled

    3. The URL in the BizTalk receive location is correct.

    Cheers


    JB

    • Marked as answer by vdha Friday, October 2, 2015 12:14 PM
    Tuesday, September 29, 2015 9:21 PM

All replies

  • Hi vdha,

    To verify your service exist and running on server please open service url on browser and press enter.

    If your service running properly then you will get screen like below,


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 2:31 PM
    Moderator
  • Did you host the service in the IIS from where you are pointing the BizTalk Receive location to?

    If it is "localhost" check the server IIS if the Service exist in the IIS and if it is pointing to some other server check that service. It should be up.

    Rahul

    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 2:33 PM
  • I didnt host anything in the IIS.. I just imported the MSI and binding file, thought it will automatically creat in the TEST server.

    How do I host the service.

    Tuesday, September 29, 2015 2:35 PM
  • Tuesday, September 29, 2015 2:42 PM
    Moderator
  • Do I need to manually publish the webservice in IIS?? Does that not created as I am importing the MSI and bindings from the DEV
    Tuesday, September 29, 2015 3:34 PM
  • Imported MSI and binding file will never publish the webservice on IIS.

    BizTalk would verify whether URL is in <http://localhost[:port]/path> format or not. If it is not in the specified format BizTalk would display the error similar to the below.

    Invalid URL "http://localhost:90/" provided as destination location. Valid format of URL is "http://localhost[:port]/path".

    For this you need to publish the services on saver and configure the port as per your service url, It should be like /virtualdirectoryname/servicename.svc


    Thanks, If my reply is helpful please mark as answer or vote as helpful.


    Tuesday, September 29, 2015 4:10 PM
    Moderator
  • Hi,

    Have you verified IIS ? Is there any virtual directory created there for your receive location .

    Don,t get confused , If your MSI contains the virtual directory information (when you export the MSI look for the steps ,it will contain definition of IIS Virtual directory ),it will generate your VD on IIS after you completely run the msi .

    Thanks

    Abhishek

     
    • Marked as answer by vdha Friday, October 2, 2015 12:13 PM
    Tuesday, September 29, 2015 4:35 PM
  • Abhishek,

    I see one of the virtual directory created in the IIS. What I see is the

    But even this when I look for it in internet explorer

    I dont know how does the other one (\ABC\Service1.svc) gets created. Do I need to do something manually. I am little confused.

    Tuesday, September 29, 2015 4:47 PM
  • Can I export the application from DEVserver IIS and import to the Test server IIS??? Does that work?? But why I cannot browse the virtual directory which is already in the Test IIS.

    • Edited by vdha Tuesday, September 29, 2015 4:57 PM
    Tuesday, September 29, 2015 4:51 PM
  • Yes you can export the MSI to any Environment .

    The MSI should contain the information for your Virtual directory . One thing you need to keep in mind is to create specific Application pool in IIS for your WCF services exposed .once created changes the virtual directory application pool from default to newly created application pool.

    Note : You also need to enable IIS 6.0 compatibility through Add/Remove program Windows --Turn windows feature on/off.

    Thank

    Abhishek

    Tuesday, September 29, 2015 5:00 PM
  • But why I am not able to browse through the <http://localhost[:port]/path> which is already in the IIS. Can you please explain me that?

    Tuesday, September 29, 2015 5:09 PM
  • Hi,

    If you see my earlier post ,you need to set IIS 6.0 compatibility mode  and need to create Application pool as well .

    This is much more of IIS configuration issue ,just see event log for more specific error   .You have exposed your service correctly now .

    If event logs is suggesting you something about IIS, let me know so that we can do more workaround .

    Thanks

    Abhishek


    Tuesday, September 29, 2015 5:15 PM
  • Abhishek,

    I tried to export import the application with the virtual directory. And I am getting the below error.What could be the reason.

    Product: ABC-Services -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action CA_Install, location: E:\Program Files (x86)\Generated by BizTalk\ABC-Services\A5C1038F-7BC4-4E85-8299-A9B6C5B0C8FC\, command: E:\Program Files (x86)\Microsoft BizTalk Server 2013\CustomAction.exe /installtype=notransaction /action=install /LogFile= /LOGFILE="" /PRODUCTNAME="ABC-Services" /PRODUCTVERSION="1.0.0.0" /PRODUCTCODE="{A5C1038F-7BC4-4E85-8299-A9B6C5B0C8FC}" /UILEVEL=5 /EXTRACTCABSONLY= /NOINSTALL= /DEPLOY= /MSITargetDir="E:\Program Files (x86)\Generated by BizTalk\ABC-Services\A5C1038F-7BC4-4E85-8299-A9B6C5B0C8FC\\" "" "C:\Users\DVELLA~1\AppData\Local\Temp\CFGE7BD.tmp"

    Tuesday, September 29, 2015 5:43 PM
  • Maybe IIS is not configured properly or  your exposed schema name is too large (more than 254 characters ) .

    You can look into app data of the exposed service for file name .

    Thanks

    Abhishek

    Tuesday, September 29, 2015 7:06 PM
  • If I give http:\\localhost\ it shows the page cannot be displayed
    Tuesday, September 29, 2015 7:07 PM
  • The Default website is not running in 80

    Tuesday, September 29, 2015 7:14 PM
  • If I give http:\\localhost\ it shows the page cannot be displayed

    Again what is the exception logged in the eventlog ?

    Have you created Application pool for the WCF servcie , Is your IIS service is up and running ?

    Have you enabled IIS 6.0 compatibility mode .

    It is much more a IIS configuration mismatch issue and until and unless you wont configure your IIS properly, you cannot browse the serve .

    Note : You need to give full path of service like http:\\localhost\virtual directory name\servicename.svc

    Thanks

    Abhishek

    Tuesday, September 29, 2015 7:14 PM
  • Hi vdha,

    Can you please verify the below?

    1. Visrual directory exists in IIS and application pool is created and started

    2. BizTalk receive location is enabled

    3. The URL in the BizTalk receive location is correct.

    Cheers


    JB

    • Marked as answer by vdha Friday, October 2, 2015 12:14 PM
    Tuesday, September 29, 2015 9:21 PM