locked
Visual Studio 2015: 'Trial Ended' / Not recognizing sign in RRS feed

  • Question

  • Hello,

    So I got the free download for Visual Studio 2015 Community and did not sign in before my trial period ran out (VS Express?). When opening VS 2015, I am prompted with a pop-up where I can choose to Sign In, Add an Account, Purchase License, etc. When I click sign in, a browser window opens that says "This page cannot be displayed". Now I figure I need this to load in order to sign in within VS 2015. I can sign in to my account on the Microsoft website but I can't get Visual Studio to recognize it. 

    Any suggestions on how to get around this?

    (ps. my default browser is Chrome, if that makes a difference)

    Thanks in advance

    Tuesday, September 1, 2015 12:04 AM

All replies

  • Hello,

    No, Registeration page will not work on Chrome. Do you have Internet explorer 11 installed on your system? If not please do it and then try to register. It should work.

    You can download it from http://windows.microsoft.com/en-us/internet-explorer/download-ie

    Do restart the system for changes to take effect.



    Please mark as answer or vote as helpful if my reply does

    • Proposed as answer by Barry Wang Tuesday, September 1, 2015 9:38 AM
    Tuesday, September 1, 2015 4:02 AM
  • @GTrippa,

    IE version is related to this issue. You may also check the following:

    1. Add live.com and Microsoft.com to your trusted sites

    2. Check you can access this site    https://app.vssps.visualstudio.com/profile/view

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, September 1, 2015 9:41 AM
  • @GTrippa,

    IE version is related to this issue. You may also check the following:

    1. Add live.com and Microsoft.com to your trusted sites

    2. Check you can access this site    https://app.vssps.visualstudio.com/profile/view

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    I added both sites. I still can't get the page to load in IE. I have version 11
    Tuesday, September 1, 2015 11:43 PM
  • @Gtrippa,

    What about switch to another account? Can you access the profile view link?

    If you are under some proxy please make sure you've configured your proxy setting, make sure it will not block your installation.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 2, 2015 8:24 AM
  • @Gtrippa,

    What about switch to another account? Can you access the profile view link?

    If you are under some proxy please make sure you've configured your proxy setting, make sure it will not block your installation.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Nope, no proxy here. Can you think of any other Internet Options settings in IE that may be preventing it from opening?

    Thanks

    Wednesday, September 2, 2015 9:44 PM
  • @Gtrippa,

    Another possible reason is Javascript, see here:

    https://support.microsoft.com/en-us/kb/2880131

    "When you disable JavaScript in Windows Internet Explorer, you cannot sign in to Microsoft Visual Studio 2013. Additionally, you cannot synchronize Visual Studio settings with other devices"

    "

    To work around this issue, enable the JavaScript feature in Internet Explorer. To do this, follow these steps:
    1. Start Internet Explorer, press Alt to reveal the Menu bar, click Tools, and then click Internet Options.
    2. Click the Security tab, and then click the Internet zone.
    3. Depending on whether you have to customize your Internet security settings, select one of the following options:
      • If you do not have to customize your Internet security settings, click Default Level.
      • If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    "

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 3, 2015 1:03 AM
  • @Gtrippa,

    Another possible reason is Javascript, see here:

    https://support.microsoft.com/en-us/kb/2880131

    "When you disable JavaScript in Windows Internet Explorer, you cannot sign in to Microsoft Visual Studio 2013. Additionally, you cannot synchronize Visual Studio settings with other devices"

    "

    To work around this issue, enable the JavaScript feature in Internet Explorer. To do this, follow these steps:
    1. Start Internet Explorer, press Alt to reveal the Menu bar, click Tools, and then click Internet Options.
    2. Click the Security tab, and then click the Internet zone.
    3. Depending on whether you have to customize your Internet security settings, select one of the following options:
      • If you do not have to customize your Internet security settings, click Default Level.
      • If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    "

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    I checked my Active Scripting and it was enabled. I tried disabling and re-enabling and it did not change the outcome. 

    Is there any other way I can activate my VS without signing in? lol

    ps. Thanks for all your help!

    Friday, September 4, 2015 2:58 AM
  • @GTryppa,

    Sorry, for the community version and the Express version, the sign in is required. For those paid version like Visual Studio 2015 Enterprise, it is supported to use a license key to active.

    If you continue to get this error, well, maybe I need to recommend you backup your settings and reinstall your system. That is much quicker than we guess the problem. And you will be happy with your coding after that.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 7, 2015 1:46 AM