locked
SSMS can't "see" mdf file so can't attach it RRS feed

  • Question

  • User224181609 posted

    I have Management Studio installed, and trying to attach to it an mdf file on my computer.

    When I try to browse to the mdf file to attach it, SSMS studion does not see the file, so I cant attach it.

    Here is what the actual file tree structure is on my C: drive:

    And here is the file structure I see when trying to browse from SSMS to find the file, which is in a sub-sub folder of Clarks but does not show:

    So to the question: How can I attach the file if I cant browse to it?  I also tried typing the path in the database file location box at the top, but the OK button was grayed out so I could not do that either.

    Am I doing something wrong? Is there some SSMS setting or authorization or the like that I have missed?

    Thursday, June 5, 2014 5:52 PM

Answers

  • User465171450 posted

    Try moving it out of your user directory. I think it's a permissions issue as it should be displaying a + sign next to the directory also since there are sub-directories. Usually a create a directory just for my databases as they can be fussy at times and may have special requirements (such as cannot be in a directory that is compressed). If you have the directory marked as shared that could be the reason but it's definitely something with the directory permissions or settings.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 5, 2014 9:12 PM
  • User224181609 posted

    Thank you for the response.

    I moved the website into a folder on C: and then I could see it with SSMS.  I could not attach the file until I discovered that I had to right-click on SSMS and Run as Administator. Upon doing that, life is good. Problem solved.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 5, 2014 10:53 PM

All replies

  • User465171450 posted

    Try moving it out of your user directory. I think it's a permissions issue as it should be displaying a + sign next to the directory also since there are sub-directories. Usually a create a directory just for my databases as they can be fussy at times and may have special requirements (such as cannot be in a directory that is compressed). If you have the directory marked as shared that could be the reason but it's definitely something with the directory permissions or settings.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 5, 2014 9:12 PM
  • User224181609 posted

    Thank you for the response.

    I moved the website into a folder on C: and then I could see it with SSMS.  I could not attach the file until I discovered that I had to right-click on SSMS and Run as Administator. Upon doing that, life is good. Problem solved.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 5, 2014 10:53 PM