locked
session timeout RRS feed

  • Question

  • User-1654133824 posted

    Hi to all.Can anyone tel me hoe to set the timeout for three hour.if the user leave the page for three hour till the session alive after three hour on submit click next page wil come.pls give me the solution for this since last one month me searching for this but no one giving me the exact answer.and now this is end time me having deadlines pls help me its argent

    Wednesday, August 17, 2011 1:26 AM

Answers

All replies

  • User1266497125 posted

    You need to do this in a web.config. Under configuration/system.web/sessionState you have an attribute timeout. Here you need to specify (in minutes) your timeout. In your case it would be 180. Here is a link for you to check: http://msdn.microsoft.com/en-us/library/h6bb9cz9%28v=VS.71%29.aspx

    Regards,

    Huske

    Wednesday, August 17, 2011 1:29 AM
  • User-2067077449 posted

    http://forums.asp.net/t/1143744.aspx/1?Managing+Session+TimeOut+using+Web+Config

    Wednesday, August 17, 2011 1:39 AM
  • User-1654133824 posted

    hello sir i have tried it in min also by giving session timeout in min but all is fine on local but not working 

    Wednesday, August 17, 2011 1:40 AM
  • User-2067077449 posted
    <system.web>
        <sessionState mode="InProc" timeout="5"></sessionState>
    </system.web>
    Wednesday, August 17, 2011 1:45 AM
  • User-1654133824 posted

    i have given the timeout as

    	<authentication mode="Windows"/>
    <sessionState timeout="10800"></sessionState>
    
    
    i have tried
    <sessionState mode="InProc" timeout="180"></sessionState>
     it is not working on server
    
    
    Wednesday, August 17, 2011 1:48 AM
  • User-1654133824 posted
    <system.web>
        <sessionState mode="InProc" timeout="180"></sessionState>
    </system.web>
    
    
    hi i have given the timeout like above but it is timeout is 3 min means it is takin in second.
    m still confuse exactly what is happening if it is in min  den y it is takin in seconds
    Wednesday, August 17, 2011 2:14 AM
  • User-2067077449 posted

    When your session expire ? according to your timeout or bydefault after 20min.

    http://stackoverflow.com/questions/1725925/how-to-set-session-timeout-more-than-20-min

    Wednesday, August 17, 2011 2:15 AM
  • User-1654133824 posted

    no my session get timeout according to my timeout 

    but if i put timeout 180 den it is timeout in 3 min it is taking in seconds

    but i need to give the timeout  for three hour 

    Wednesday, August 17, 2011 2:34 AM
  • User-2067077449 posted

     yes it is taking in second. try to set timeout=10800 for three hour.

    Wednesday, August 17, 2011 2:43 AM
  • User-1654133824 posted

    i have tried using timeout=10800 also but it is working fine on local but not on server.if my page is steady more than one or two hour and then i click the submit button no action is fired even on submit button i have write the respose.redirect still it not redirected to the next page.

    and one more question if it is in min then y it is taking in seconds

    Wednesday, August 17, 2011 2:47 AM
  • User-2067077449 posted

    How can u say that it is min ?

    Try this...

    Change the following time-outs in Internet Services Manager .Choose a value greater than the default of 20.

    1. Select Default Web Site > Properties > Home Directory > Application Settings > Configuration > Options.

    2. Enable the session state time-out and set the Session timeout for 60 minutes.

    3. Select Application Pools > DefaultAppPool > Properties.

    4. From the Performance tab under Idle timeout, set Shutdown worker processes after being idle for a value higher than 20.

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    Symptom

    When returning to the logon page for Web Interface, users often encounter an Error: Your session with the web-server expired. You have been logged out.

    Cause

    Web Interface 2.0 picks up the session timeout setting from IIS.

    Resolution

    1. Start Internet Services Manager 5.0.

    2. For explicit authentication, right-click the /Citrix/MetaFrameXP/default virtual directory and view the Properties.

    For desktop credentials, pass-through users edit the /Citrix/MetaFrameXP/integrated virtual directory.

    For Smart Card users, edit the /Citrix/MetaFrameXP/certificate virtual directory.

    3. In the Application Settings section, click Configuration.

    4. Select the App Options tab.

    5. Ensure Enable session state is selected.

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    NFuse Classic 1.71 and earlier

    When Internet Explorer is configured never to check for newer versions of Web pages, NFuse Classic will not launch an application after a session is allowed to expire. To reproduce this problem:

    1. Configure your browser settings for 'Temporary Internet files and set Check for newer versions of stored pages to Never.

    2. Log on to Citrix NFuse Classic and view your published applications.

    3. Leave the system idle for 20 minutes or longer so that the Web server session expires.

    4. Click an application icon. The system returns you to the Logon page and a message appears stating that your session expired.

    5. Log on again and click the same application as before. You are again returned to the Logon page even though your session should not have expired this time.

    Solutions

    • Clear the Temporary Internet Items folder

    • Upgrade to Web Interface 2.0 or later

    • Set Check for Newer versions of stored pages to Automatically

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    NFuse 1.6

    This error is caused by the expiration of a Web server session, not a MetaFrame ICA session. Web servers maintain session state for a fixed time period to preserve Web server resources and as a security precaution. The default setting for IIS is 20 minutes. Do not remove this timeout. However, the timeout can be modified in the following ways (assuming your Web server is Microsoft IIS):

    1. Open Internet Services Manager.

    2. From the Web site Properties, click the Home Directory tab, then click the Configuration... button in the Application Settings section.

    3. On the configuration panel, click the App Options tab and set the session timeout there.

    4. In NFuse 1.6, add this line to the end of redirect.asp:

    <% Session.Timeout = 20%>

    where 20 is the number of minutes after which an idle session will time out.

    Increasing this value improves usability, preventing users from having to enter their credentials too frequently.

    Decreasing this value improves security; if a user leaves his desk unattended with the NFuse application list showing, other users can launch applications using the account. The session time out acts as an idle time out and prevents this type of abuse.

    Wednesday, August 17, 2011 2:53 AM
  • User-1654133824 posted

    hi m using the IIS 5.1 in that m not finding Default Application Pool Properties what should i do then

    Wednesday, August 17, 2011 2:57 AM
  • User-2067077449 posted

    Hi,

    I dont have IIS 5.1 to check But hope that changing the Session time out with <httpRuntime> Element options will help you.

    For details please visit the site

    http://msdn.microsoft.com/en-us/library/e1f13641(v=vs.71).aspx

    and try to set the idleTimeOut option.

    Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 17, 2011 5:38 AM