none
Creating a custom Home Tab and hiding TabHome RRS feed

  • Question

  • It has been requested that we create a custom Home tab for frequently used commands in our environment using the Cusom UIEditor.  I have tried 2 methods, neither one of which is working as hoped:

    Method 1.  Hide all groups on Home tab and add custom groups.  When I set the groups one by one to hide, the GroupClipboard appears anyway.  There is also an "add-in" group that I can't hide (which we don't use at all) because I don't know the tab id.  Is there a way to hide all groups on a tab and then customize?

    Method 2.  I tried creating a custom Home tab.  I can add all the groups, but because we have an add-in that (my guess) uses an insertAfterMso="TabHome" command, when I hide the Home tab, Word freezes.  If I don't hide the built-in Home tab, Word does not freeze, but then I have two Home tabs.

    Any ideas how to solve my dilemna?


    • Edited by orlandp Friday, June 22, 2012 6:43 PM
    Friday, June 22, 2012 12:43 AM

Answers

  • Hi,

    Given you don't have access to that addin(InsertAfterMso=TabHome), you cannot hide the Home tab. Otherwise, you can hide Home tab by Options, -> customize ribbon -> Uncheck Home tab in the right.

    thanks,


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Proposed as answer by Forrest GuoModerator Wednesday, June 27, 2012 9:19 AM
    • Marked as answer by orlandp Wednesday, June 27, 2012 8:29 PM
    Wednesday, June 27, 2012 9:19 AM
    Moderator

All replies

  • Hi Orlandp,

    Thank you for posting in the MSDN Forum.

    I'll involve some experts who are more familiar with your issue. This may take some time.

    Much appreciate for your patience and understanding.

    Best regards,
    Quist


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, June 26, 2012 6:21 AM
    Moderator
  • Hi,

    Given you don't have access to that addin(InsertAfterMso=TabHome), you cannot hide the Home tab. Otherwise, you can hide Home tab by Options, -> customize ribbon -> Uncheck Home tab in the right.

    thanks,


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Proposed as answer by Forrest GuoModerator Wednesday, June 27, 2012 9:19 AM
    • Marked as answer by orlandp Wednesday, June 27, 2012 8:29 PM
    Wednesday, June 27, 2012 9:19 AM
    Moderator