locked
VS 2008 & Blend RRS feed

  • Question

  • My epartment recently upgraded from VS 2005 to VS 2008 (& Framework 3.5). Afterward I opened a project I had been working on for some time and got all kinds of new errors.

    For example:
    The name "Grid" does not exist in the namespace http://schemas.microsoft.com/winfx/2006/xaml/presentation.

    I get these kinds of errors for may many controls and on every page I try to open. Because of these errors, the Blend designer doesn't show me anything (just says "Invalid XAML"). Because of all the errors I downloaded Expression Studio 2 Beta. When I open the same project there, I get no errors and all the pages open fine.

    So, what's wrong with v1?
    Wednesday, April 30, 2008 8:27 PM

All replies

  • sryan,

    Off the top of my head, it sounds like you need to install the Microsoft Expression Blend Service Pack 1, otherwise Blend does not work with .NET 3.5.  The Blend 2 Beta works because it has that fix already.

    Best regards,

    Jonathan - MSFT

    This posting is provided "AS IS" with no warranties and confers no rights
    Wednesday, April 30, 2008 8:55 PM
  • Sorry, I already have the sp1 installed. Installed it as soon as it was made available.
    Thursday, May 1, 2008 11:59 AM
  • If your project is Silverlight, that might explain it, because Blend SP1 cannot open or create Silverlight projects.  Otherwise, without having the project in hand, it's hard to say what's going on.

    Jonathan - MSFT


    This posting is provided "AS IS" with no warranties and confers no rights
    Thursday, May 1, 2008 11:51 PM
  • This is a regular wpf desktop application project that was created in VS 2005 (with the orcas beta plugin) and modyfied in Blend v1. Then modyfied further with Blend v1 sp1. After upgrading from VS 2005 to VS 2008 (removing the orcas plugin and installing framework 3.5) Blend v1 sp1 started provided me strange errors just opening the project (as mentioned above). Like not knowing what a Grid or a ComboBox was. As if it couldn't find their definitions in microsoft's schemas. I installed Blend v2 Beta just out of curiousity and the project opened without errors.

    So my question is, why would Blend v1 sp1 get errors just because I installed VS 2008? And why would Blend v2 not get those same errors? Could it because I don't have the Orcas plugin installed anymore? Would Blend v1 care about that? Or because I don't have the same Frameworks installed anymore? I only have 2.0 sp2 & 3.5 now (before I had 1.0 & 2.0 too).
    Friday, May 2, 2008 12:11 PM
  • That's curious.  I'll have to look into that further.  Thank you for the clarification.  I'm not with the product group, but, if I find something, I'll file it so they can test it further.

    Thanks, again!

    Jonathan - MSFT

    This posting is provided "AS IS" with no warranties and confers no rights
    Friday, May 2, 2008 5:05 PM