none
Party Information not Validated during X12 Inbound Transaction in BTS 2009 RRS feed

  • Question

  • Hi,

    I am loading an X12 835 file to Database. I have not created any Pary. I used EDI Dissassembler in the Pipeline. The file was loaded into the Database without any issues. The ISA,GS values loaded into the Database are the same as in the file. This shows that the Party is not validated during Inbound Transaction. Can anyone tell me whether I have to change any settings before loading any Inbound file to match with the Party.
    Monday, December 7, 2009 11:58 PM

All replies

  • Hi RSubha,

    If BizTalk Server cannot determine the party for either an incoming or outgoing message, it will use the EDI global properties to process the incoming interchange or generate the outgoing interchange. The EDI global properties are set by right-clicking the Parties node in the BizTalk Server Administration Console and clicking EDI Global Properties.
    You need to Add and configure a Party to have the explicit validation and custom setting needed for your Party.

    Please refer below link to configure the Party.

    http://msdn.microsoft.com/en-us/library/bb246069(BTS.20).aspx

    Regards
    Vishnu
    Vishnu
    • Edited by callvishnu Tuesday, December 8, 2009 8:34 AM Added the URL
    Tuesday, December 8, 2009 8:31 AM
  • Hi Vishnu,

    If BizTalk is taking the EDI global properties then it should insert the Sender and Receiver information from Global properties into the database. I am inserting the ISA and GS values into a table in the database. But even if there is no party available, it is inserting the Sender and Receiver information in the file into the database instead of the global values. Please explain.

    Thanks and Regards,
    R.Subha

    Saturday, December 12, 2009 11:09 PM
  • If you are not using the EdiReceive or EdiSend pipeline components (directly or indirectly), the party information including the global properties will not be used.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Sunday, December 13, 2009 6:41 PM
    Moderator