locked
VS 2015 Community - default web app templates doesn't compile and run RRS feed

  • Question

  • I've been experiencing some weird issues with the VS 2015 community editon. I've had installed the VS 2015 (earlier version, beta) then uninstalled and installed it again with the asp.net 5 RC1-final.

    When I try creating a new project from the built-in templates (ASP.NET web application->ASP.NET preview templates->web application) I can't build it, can't restore packages from VS.

    In the project.json I can see that all of the dependencies are beta-5 instead of RC1 ?

    Project.json

    "dependencies": {
        "EntityFramework.SqlServer": "7.0.0-beta5",
        "EntityFramework.Commands": "7.0.0-beta5",
        "Microsoft.AspNet.Mvc": "6.0.0-beta5",
        "Microsoft.AspNet.Mvc.TagHelpers": "6.0.0-beta5",
        "Microsoft.AspNet.Authentication.Cookies": "1.0.0-beta5",
        "Microsoft.AspNet.Authentication.Facebook": "1.0.0-beta5",
        "Microsoft.AspNet.Authentication.Google": "1.0.0-beta5",
        "Microsoft.AspNet.Authentication.MicrosoftAccount": "1.0.0-beta5",
        "Microsoft.AspNet.Authentication.Twitter": "1.0.0-beta5",
        "Microsoft.AspNet.Diagnostics": "1.0.0-beta5",
        "Microsoft.AspNet.Diagnostics.Entity": "7.0.0-beta5",
        "Microsoft.AspNet.Identity.EntityFramework": "3.0.0-beta5",
        "Microsoft.AspNet.Server.IIS": "1.0.0-beta5",
        "Microsoft.AspNet.Server.WebListener": "1.0.0-beta5",
        "Microsoft.AspNet.StaticFiles": "1.0.0-beta5",
        "Microsoft.AspNet.Tooling.Razor": "1.0.0-beta5",
        "Microsoft.Framework.Configuration.Abstractions": "1.0.0-beta5",
        "Microsoft.Framework.Configuration.Json": "1.0.0-beta5",
        "Microsoft.Framework.Configuration.UserSecrets": "1.0.0-beta5",
        "Microsoft.Framework.Logging": "1.0.0-beta5",
        "Microsoft.Framework.Logging.Console": "1.0.0-beta5",
        "Microsoft.VisualStudio.Web.BrowserLink.Loader": "14.0.0-beta5"
      },

    In the DNVM I can see the following:

    Active Version         Runtime Architecture Location                     Alias
    ------ -------         ------- ------------ --------                     -----
           1.0.0-beta5     clr     x64          C:\Users\Kamil\.dnx\runtimes
           1.0.0-beta5     clr     x86          C:\Users\Kamil\.dnx\runtimes
           1.0.0-beta5     coreclr x64          C:\Users\Kamil\.dnx\runtimes
           1.0.0-beta5     coreclr x86          C:\Users\Kamil\.dnx\runtimes
           1.0.0-rc1-final clr     x64          C:\Users\Kamil\.dnx\runtimes
      *    1.0.0-rc1-final clr     x86          C:\Users\Kamil\.dnx\runtimes def...
           1.0.0-rc1-final coreclr x64          C:\Users\Kamil\.dnx\runtimes
           1.0.0-rc1-final coreclr x86          C:\Users\Kamil\.dnx\runtimes
    Wednesday, November 25, 2015 9:21 AM

Answers

  • Hi KamilZO,

    Thank you for posting in MSDN forum.

    >>System.IO.FileNotFoundException: Could not load file or assembly 'dnx.clr.managed' or one of its dependencies. The system cannot find the file specified

    I did a research and found a similar issue as yours, you may refer to Chris's reply:

    http://stackoverflow.com/questions/31389153/missing-assembly-dnx-clr-managed

    Here is his workaround:

    Deleting everything and re-published with new profile and the page loaded.

    You may have a try about it.

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by 宝宝徐 Tuesday, December 1, 2015 2:24 AM
    • Marked as answer by 宝宝徐 Wednesday, December 2, 2015 8:23 AM
    Thursday, November 26, 2015 9:28 AM

All replies

  • Here is the output in the browser:

    Server Error in '/' Application.

    Could not load file or assembly 'dnx.clr.managed' or one of its dependencies. The system cannot find the file specified.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'dnx.clr.managed' or one of its dependencies. The system cannot find the file specified.

    Wednesday, November 25, 2015 9:30 AM
  • Hi KamilZO,

    Thank you for posting in MSDN forum.

    >>System.IO.FileNotFoundException: Could not load file or assembly 'dnx.clr.managed' or one of its dependencies. The system cannot find the file specified

    I did a research and found a similar issue as yours, you may refer to Chris's reply:

    http://stackoverflow.com/questions/31389153/missing-assembly-dnx-clr-managed

    Here is his workaround:

    Deleting everything and re-published with new profile and the page loaded.

    You may have a try about it.

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by 宝宝徐 Tuesday, December 1, 2015 2:24 AM
    • Marked as answer by 宝宝徐 Wednesday, December 2, 2015 8:23 AM
    Thursday, November 26, 2015 9:28 AM