locked
Unable to install lightswitch desktop Application for out-of-browser use RRS feed

  • Question

  • Hello,

    I'm a beginner in lightswitch. I create a desktop app with intraseq database. Just a simple table with 2 columns. I publish it to my azure website and database. Everything is fine.

    When I go to mysite/DesktopClient, I have the install button but when I click on it, it says (I try to traduce the french message...) : This application cannot be save for out of browser use and I can't install it.

    When i choose Web in the desktopclient properties, everything is fine within the web browser. I can use the app from my azure website

    Am I missing something ?

    Thanks for you help and sorry if this question was already answered, I spent a bunch of time, but I don't see what's wrong.



    • Edited by JPO59 Sunday, October 12, 2014 11:30 PM
    Sunday, October 12, 2014 11:02 PM

Answers

All replies

  • I used it several times from IIS on-promise server that works fine. If Azure complains it can not work from outside browser assume that it is not supported. But perhaps i am wrong.

    Eric

    Monday, October 13, 2014 8:59 AM
  • Thanks for your answer Eric.

    I'm not sure I get it though... Why it should not be supported ?

    I tried to follow many tutorials like the one that Beth Massi did but it seems that the way to do it slightly change since the VS 2013

    Monday, October 13, 2014 9:31 AM
  • I've installed SL client in OOB without problem on azure websites, but SSL cert is required when deploy it.

    I've used self-signed cert ;-)

    Monday, October 13, 2014 9:45 AM
  • Thanks fileman,

    When I used the deployment wizard, i specify an auto generate certificate. When I followed Beth Massi's tutorial, she was talking about importing the certificate to the azure server but I can't manage how to do it in the new portal interface.

    Should I somehow exporting the certificate to the azure server ?

    Thanks

    Monday, October 13, 2014 9:59 AM
  • Hello again,

    I did manage to upload the cerficate in the azure website. For this, I saved the certificate in a file (from the publish wizard) and i uploaded it in the server.

    Still have the same problem.

    Thank for your help

    Monday, October 13, 2014 1:00 PM
  • You don't need to use HTTPS/SSL with a certificate, but you DO need to digitally sign the XAP.  Here is an old blog post about it, the publish wizard is a little different now, but this should get you in the right direction.

    http://blogs.msdn.com/b/mwade/archive/2011/06/13/lightswitch-application-client-configuration-and-signing.aspx


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Monday, October 13, 2014 4:37 PM
    Moderator
    • Proposed as answer by fileman Monday, October 13, 2014 4:40 PM
    • Marked as answer by JPO59 Tuesday, October 14, 2014 6:12 PM
    Monday, October 13, 2014 4:39 PM
  • Hello Fileman,

    Thanks, with this, i did manage to publish AND install it for out-of-browser use.

    In fact, I followed by mistake this first part of the tutorial which was about publishing to cloud. And in the wizard, there is a button to upload the certificate. That's how I managed to upload it.

    I cancelled the wizard, then I retry it but this with the option to publish to the website. It works :)

    I can install the application and launch it for my desktop. 

    Still have a problem though, there is a red cross in the tables rows saying "unable to load data", when I try to create a new item and save, I have the error "the underlying provider failed on Open"

    At least, I can install it, this is already a good thing ;)

    Thanks

    Edit : after activating the log in the website, here the error details : Microsoft.LightSwitch.DataServiceOperationException: The underlying provider failed on Open. ---> System.Data.EntityException: The underlying provider failed on Open. ---> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
    • Edited by JPO59 Tuesday, October 14, 2014 6:07 PM
    Tuesday, October 14, 2014 5:53 PM
  • did you have set azure sql server connectionstring in the publish wizard?

    if no, go to azure web site setting and get connectionstring of sql azure db, if not exist create new db and attach as resource to website

    Tuesday, October 14, 2014 7:51 PM
  • Yes I did, the db is link to the website. I did this in the link ressources of the website
    Tuesday, October 14, 2014 8:42 PM
  • Yes I did, the db is link to the website. I did this in the link ressources of the website

    And also, I have some tables that come from my local sql server database.

    Since the beginning of this message, I decided to migrate to not use the intrinsic db because I want to be able to manage my primary keys. 

    So I have now two datasources for my test, the intrisic and the sqlexpress datasource. I'm gonna try only with intrisic first.

    Tuesday, October 14, 2014 8:50 PM
  • Yes, that's it. I shoud have check before what tables where published... only aspnet tables and the local intrasec table.

    I tried to run locally my database creation script but it seems that i have deprecated method "Drop index", the syntax have changed but this is another subject.

    I will try tomorrow, right now I need a some sleep ;) 

    step by step, i should finally manage to do it, hope It's not too late to learn lightswitch ;) !

    Thanks


    • Edited by JPO59 Tuesday, October 14, 2014 10:14 PM
    Tuesday, October 14, 2014 10:11 PM