none
Reportviewer - doesn't show a report on my pc only RRS feed

  • Question

  • This is the first time I am working with Microsoft Reporting Services and ReportViewer v11.0.0.0. There is a project on Visual Studio 2010 with SQL Server 2008 and ReportViewer v11.0.0.0. This project can be run in another computers, but for my computer when I run the project, after inputting the parameters, I receive a blank page (all white), basically reportviewer does not show the report that is seen on another computers.

    // .net
    <%@ Register Assembly="Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.Reporting.WebForms" TagPrefix="rsweb" %>
    <form id="form1" runat="server" >
        <asp:ScriptManager ID="ScriptManager1" runat="server" ScriptMode="Release" AsyncPostBackTimeout="600" />
        <rsweb:ReportViewer ID="rv" runat="server" AsyncRendering="true" Width="100%" Height="900px" ProcessingMode="Remote" ShowPrintButton="false" onreporterror="rv_ReportError"/>
    </form>
    
    // c#
    rv.ProcessingMode = ProcessingMode.Remote;
    rv.ShowParameterPrompts = false;
    rv.ShowRefreshButton = false;
    
    rv.ServerReport.Timeout = 12500000;
    rv.ServerReport.ReportPath = reportViewerModel.ReportPath;
    
    rv.ServerReport.ReportServerUrl = new Uri(AppUtil.GetReportExecutionUrl());
    
    rv.ServerReport.SetParameters(reportViewerModel.ReportParameters);
    rv.ServerReport.Refresh();

    The code is like above, but I don't think there is something we need to do on the code since this is working for another computers. I tried many things like below but couldn't fix:

    1. EnablePartialRendering: true (for ScriptManager),

    2. AsyncRendering: false,

    3. Uninstalling/Installing the reporting services and reportviewer. Trying the previous versions too.

    4. Remove and add webforms.dl and winforms.dll again to the project from GAC (windows/assembly/gac_msil)

    5. Changing target url while installing reporting services: (localhost/Reportserver is now, it is up and working).

    I am stucked right now. I checked all the related questions and tried their solutions one by one but none of them solved it. I do not know what can I else do? What should I check, where do I need to focus?

    Any idea would be appreciated.

    - There is no error message received at some point. Result in same for both IE and Chrome.



    Friday, February 12, 2016 3:12 PM