locked
DssDeploy Unpacking Problem RRS feed

  • Question

  • I am having problems unpacking files with DssDeploy on RDS 2008 Express.  The created package does not recognize that the computer has RDS 2008 Express on it. 

    I pack the files with a command like so:

    dssdeploy.exe /p /l:"Foo.rtf" /cv:true /s:false /ac:"Foo" /acp:"Foo" /at:"Foo" /n:"Foo" /r:"Foo.pdf" @List.txt Output.exe

    and the List.txt file contains many “/m” and “/d” lines.  There are simulation projects included here.

    The package gets created fine, but when I run it on another computer that has RDS 2008 Express on it, or even the same computer I created the deploy with, I get a message saying that “Microsoft Robotics Developer Studio 2008 Express Edition was not detected.”  That was when i tried to unpack the package by just double clicking it.  When i run DssDeploy /unpack from a RDS shell i get this error:
    *** This package was created to be deployed into a specific version of Microsoft Robotics Developer Studio. Please use the '/specific' command line option.

    Which is very strange since there is no documentation of a '/specific' command line option.

    I ran Paul’s DssDeploy inspector tool and here are some interesting notes:

    It gave me an error message saying that the package is not labeled as a DssDeploy self extractor.  Also, the Name tag in the tool says <empty> even though I specified it in the DssDeploy command line.  But other than that, all files in the package looked fine.

    As a side note, of all 4 combinations of the DssDeploy command line options: /cv and /s, only /cv:true /s:false works for me.  If /cv is false, then I get an error that some assemblies can only be added to the deploy if /cv = true.  And if both are set to true, then I get an error about not being able to set file permissions when targeting an existing installation.  It seems like the /e option (which was removed) would really help things here…

    www.coroware.com
    Thursday, April 9, 2009 12:46 AM

Answers

  • There is a bug in the /cv option in RDS 2008. I think this has been discussed before.

    There is a workaround using the /dvg option. Please look at the Known Issues Wiki:
    http://msdn.microsoft.com/en-us/library/bb977678.aspx

    The /specific command-line option only applies to the package, not DssDeploy. We noticed recently (as part of our QA) that there was no documentation for this. It will be fixed in a future release.

    Trevor
    Wednesday, April 15, 2009 6:57 AM