locked
Problems Deploying Project

    Question

  • I get the following message every time I try to deploy:

    The project '___' cannot be started directly.
    In order to debug this project, you must consume it from a Metro style app project that creates a package and is marked as the Startup Project.

    If I go into my Configuration Manager, every checkbox under the Deploy column is grayed out. I am able to deploy other projects, just not this particular one.

    Any ideas?

    Friday, May 18, 2012 1:12 AM

Answers

  • Figured it out; in order to deploy your Metro project, the project's .vcxproj file needs to have the following tag in it's <PropertyGroup Label="Globals"> tag:
        <AppContainerApplication>true</AppContainerApplication>

    Without this tag, the deploy checkbox is permanently locked down. I guess it was overwritten or lost somehow in the build upgrade.

    • Marked as answer by inspira Monday, May 21, 2012 7:53 PM
    • Edited by inspira Monday, May 21, 2012 7:54 PM
    Monday, May 21, 2012 7:53 PM

All replies

  •  

    Hello,

     

    Would you please tell us the detail of this app? What function do you want to achieve.

     

    This forum is talking about the metro style app development.

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, May 18, 2012 2:47 AM
  • Sorry, I should have specified earlier, this is a C++ Metro App that was working and deployable as of Win8 build 8250. Previously if I opened the Solution Property Pages, or the Configuration Manager, I am able to select which projects I want to build/deploy. As of the latest Win8 build all selections under the deploy column are deselected, and every box is grayed out. Everything builds correctly though (after adapting to all the new API changes).

    I'm unable to specify the exact details of the project, all I can say is that there are a couple projects in my solution, all of which compile, and none of which I can deploy. I have not been able to get the 'Deploy' checkbox reenabled, even after reverting to my old solution file. Any help would be greatly appreciated!
    • Edited by inspira Saturday, May 19, 2012 12:07 AM
    Friday, May 18, 2012 5:44 PM
  • Figured it out; in order to deploy your Metro project, the project's .vcxproj file needs to have the following tag in it's <PropertyGroup Label="Globals"> tag:
        <AppContainerApplication>true</AppContainerApplication>

    Without this tag, the deploy checkbox is permanently locked down. I guess it was overwritten or lost somehow in the build upgrade.

    • Marked as answer by inspira Monday, May 21, 2012 7:53 PM
    • Edited by inspira Monday, May 21, 2012 7:54 PM
    Monday, May 21, 2012 7:53 PM