none
ProjectSchedulingEngineException when trying to save project RRS feed

  • Question

  • Hi,

    I'm trying to save a project in PWA and I'm getting the following error (only for 1 project). Any idea?

    • Project:
      • ProjectSchedulingEngineException (9133). Details: id='9133' name='ProjectSchedulingEngineException' uid='796dd35a-264e-4b10-91a0-589fb04a2ef0' exception='System.InvalidOperationException: Failed to compare two elements in the array. ---> System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Office.Project.Scheduling.CalendarFunctionality.DayTypeAndWorkDefinitionComparer.Compare(Object x, Object y) at System.Array.BinarySearch(Array array, Int32 index, Int32 length, Object value, IComparer comparer) --- End of inner exception stack trace --- at Microsoft.Office.Project.Server.BusinessLayer.ProjectSchedule.Schedule() at Microsoft.Office.Project.Server.BusinessLayer.ProjectMain.HandleProject(ProjectDataSet dataset, Guid projectUid, Boolean fSkipSchedulingCalc, Guid userUid, String userName, Boolean isNew, Boolean addColumns, ProjectLocks projectLock, Boolean fCheckReadOnly, Boolean fCheckProtectedActuals, Boolean fAllowAddEntRes, Boolean fOptIndexRecalced, Guid templateUid, Boolean fSkipCfFormulaCalc)'.
    • Queue:
      • GeneralQueueJobFailed (26000) - ProjectUpdate.ProjectUpdateMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='b7f2c12e-5681-4c3e-befa-546aa154f995' JobUID='ed08700a-5208-4922-ab50-8a56d5fd4138' ComputerName='xxxxx' GroupType='ProjectUpdate' MessageType='ProjectUpdateMessage' MessageId='2' Stage=''. Überprüfen Sie die ULS-Protokolle auf dem Computer XXXXX auf Einträge mit JobUID ed08700a-5208-4922-ab50-8a56d5fd4138, um weitere Details anzuzeigen..

    Best regards,

    Daniel

    Monday, December 17, 2012 6:37 PM

All replies

  • Hi Daniel,.

    It looks like that project data is corrupted & that's why it's throwing the  ProjectSchedulingEngineException On  save/publish.

    Please have a look at the similar thread:
    http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/c46bfe05-4615-4736-98b4-e626d933b10d

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Proposed as answer by Jack-EPM Saturday, December 22, 2012 4:31 PM
    • Unproposed as answer by DanielS. _ Thursday, December 27, 2012 1:55 PM
    Tuesday, December 18, 2012 4:54 AM
  • Hi,

    thanks for your reply, I checked similar threads and nothing worked for my project plan.

    I opened a microsoft support case for this issue and unfortunately there seems to be no chance to fix this in with reasonable effort. This is probably an issue with the server side calculation engine. Using Project Prof (which uses a client based calculation engine) works well. In my opinion, the only chance is closing the corrupted project and create a new one. I'm not happy with this solution but I don't think there's another way.....

    Best regards,

    Daniel

    Thursday, December 27, 2012 2:02 PM
  • Hi Daniel,

    I had the similar issue for one of my customer for a specific issue. We had few missing link & dependecy related issues in plan that we were not able to fix it manually. Finally, I had to save the plan as XML & re-import as a project to overwrite the existing one. It fixed the issue.

    Did you try the above for the project? You may just re-import the xml file as a different project for testing & try saving it & if that works, you may again re-import to overwrite the existing plan & later delete the plan that you created for testing.

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Friday, December 28, 2012 6:57 AM
  • Hi Amit,

    saving the plan as XML and re-import it as a project did not fix the issue - unfortunately. We already checked this! We're fairly certain the problem is related to the server side calculation engine.

    Best regards,

    Daniel

    Wednesday, January 2, 2013 8:40 AM
  • Hi Daniel,

    I would think another workaround to try with:
    http://www.projectserverhelp.com/Lists/Posts/Post.aspx?List=f884b43f-61db-4c4e-94a3-38f21a8efdad&ID=197&Web=28a89920-6690-45b4-9132-339c2f40a7e7

    Another similar thread might help:
    http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/7209dde6-4d78-4921-bcef-ad838db42b30/

    If above options don't work, probably closing the corrupted project & create a new one is the only option.

    HTH,


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82


    Wednesday, January 2, 2013 10:10 AM
  • Hi Daniel,

    Could you ping me offline regarding the support case - I'd like to drill in a bit more to see what else we could have done?  Brian.Smith@Microsoft.com

    Thanks,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Friday, January 4, 2013 9:20 PM
    Owner
  • Hi Brian,

    thank you for your offer. But we already invested more time and money in the support case than we planned. We just closed the project and created a new one - which ist time consuming and annoying....but better than working on the corrupted project without being sure the bug is fixable. We already closed the support case.

    Best regards,

    Daniel

    Thursday, January 10, 2013 5:27 PM