none
IntelliSense and editor options

    Question

  • I just upgraded from VC++2010 to VS2015 and I have a few problems: (I'm coding in C++)

    1. Even when I type a single character in the edit, IntelliSense offers me all the available keywords.

    I really don't like that. I want it to offer me the available keywords only after I mention an appropriate scope, like a class or a namespace. Example:

    Is there a way to change that?

    2. I don't like the editor playing with my marker position when I open brackets or string apostrophes. I also don't want the editor to enter the second bracket/apostrophe for me. Is it possible to change that too?

    3. Where can I change the "class" objects highlight from bright green to non?

    Thanks!


    • Edited by Paprica Thursday, December 24, 2015 3:31 PM
    Thursday, December 24, 2015 3:10 PM

Answers

  • Hi Paprica,

    Thanks for your post.

    >> when I type a single character in the edit, IntelliSense offers me all the available keywords.

    As far as I know. It’s a new feature in VS2015.

    And I can’t find any setting option about it.

    Generally you can disable intelliSense option with following path:

    Tools->Options->Text Editor->C/C++->Advanced. Set “True” in Disable IntelliSense.

    Best  Regards,

    Lake Xiao


    Friday, December 25, 2015 6:31 AM
    Moderator
  • Hi Paprica,

    For another two questions.

    >>I also don't want the editor to enter the second bracket/apostrophe for me. Is it possible to change that too?

    Please disable the Automatic brace completion. Tools->Options->Text Editor->C/C++, disable the “Automatic brace completion”

    >>Where can I change the "class" objects highlight from bright green to non?

    May be you could set it with following path,Tools->Options->Environment->Fonts and Colors. Search the C++ Class Templates in display items. Then change the color.

    Best Regards,

    Lake Xiao

    Friday, December 25, 2015 6:33 AM
    Moderator

All replies

  • Hi Paprica,

    Thanks for your post.

    >> when I type a single character in the edit, IntelliSense offers me all the available keywords.

    As far as I know. It’s a new feature in VS2015.

    And I can’t find any setting option about it.

    Generally you can disable intelliSense option with following path:

    Tools->Options->Text Editor->C/C++->Advanced. Set “True” in Disable IntelliSense.

    Best  Regards,

    Lake Xiao


    Friday, December 25, 2015 6:31 AM
    Moderator
  • Hi Paprica,

    For another two questions.

    >>I also don't want the editor to enter the second bracket/apostrophe for me. Is it possible to change that too?

    Please disable the Automatic brace completion. Tools->Options->Text Editor->C/C++, disable the “Automatic brace completion”

    >>Where can I change the "class" objects highlight from bright green to non?

    May be you could set it with following path,Tools->Options->Environment->Fonts and Colors. Search the C++ Class Templates in display items. Then change the color.

    Best Regards,

    Lake Xiao

    Friday, December 25, 2015 6:33 AM
    Moderator