none
Does Entity Framework 5 works on windows xp sp3? RRS feed

Answers

  • The 4.4. dll is the version used for .NET 4.0.

    I would do things the other way round. Anyway if you want to target XP you have no choice, so just try to see if the EF5 feature you want is available...


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".

    • Marked as answer by iglezos Friday, November 9, 2012 9:05 AM
    Friday, November 9, 2012 8:58 AM

All replies

  • Hi,

    AFAIK yes and no ;-) EF5 installs one DLL that works with .NET 4 (so I don't see why this one couldn't work) and one that supports .NET 4.5 (which is AFAIK not supported in XP).

    And you have most new features that are .NET 4.5 only so it likely depends on what exactly you want to use from EF5. See http://blogs.msdn.com/b/adonet/archive/2012/08/15/ef5-released.aspx for details...

    If you tried something (installing ?) and it fails, it's likely better to directly describe your issue.


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".

    Thursday, November 8, 2012 5:10 PM
  • when i use .net framework 4 then the entity framework 5 uses a dll with version 4.4

    the link you privided above says

    "Some features are only available when writing an application that targets .NET 4.5. This includes enum support, spatial data types, table-valued functions and the performance improvements."

    so are these the only differences?

    Friday, November 9, 2012 6:45 AM
  • The 4.4. dll is the version used for .NET 4.0.

    I would do things the other way round. Anyway if you want to target XP you have no choice, so just try to see if the EF5 feature you want is available...


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".

    • Marked as answer by iglezos Friday, November 9, 2012 9:05 AM
    Friday, November 9, 2012 8:58 AM