none
Strange dependency on .NET framework v3.5.21022 RRS feed

  • Question

  • Hi, I have a project which used to be built using Visual Studio 2010 setup project. It creates a msi installation file and everything works fine. It was a year ago. 

    Now I upgraded to Visual Studio 2015 Community, and upgraded all the project from .NET framework 4.0 client profile to .NET framework 4.5. I also installed the setup extension to Visual Studio 2015, so I can continue to use the setup project to produce the msi installation file.

    However, when I ran the new msi, it pop ups a message box saying:

    This setup requires the .NET Framework version v3.5.21022. Please

    install the .NET Framework and run this setup again. The .NET Framework

    can be obtained from the web. Would you like to do this now?

    I have checked the prerequisites of the setup project and there is no requirement on this .NET framework v3.5.21022. I have also done a text search in the whole project folder using WinGrep, and there is no "21022" anywhere.

    Why did the setup msi require this .NET Framework version v3.5.21022? Was it because .NET Framework 4.5 needs 3.5?



    • Edited by MGA3121 Monday, October 19, 2015 11:19 AM
    • Moved by Weiwei Cai Tuesday, October 20, 2015 7:23 AM .net framework related.
    Monday, October 19, 2015 11:18 AM

Answers

  • Worked out: the Launch Conditions still specifies .NET framework 3.5. Once I change it to 4.5 problem is solved.
    • Marked as answer by MGA3121 Tuesday, October 20, 2015 9:48 AM
    Tuesday, October 20, 2015 9:48 AM

All replies

  • >Why did the setup msi require this .NET Framework version v3.5.21022? Was it because .NET Framework 4.5 needs 3.5?

    I recently hit what I think is the same issue. Have a look at this and
    see if adding that setting to your project files fixes it.

    https://support.microsoft.com/en-us/kb/2735477

    Dave

    Monday, October 19, 2015 1:07 PM
  • Hmm, my response hasn't shown up. Perhaps it will after this post from the web site.
    Monday, October 19, 2015 2:50 PM
  • So it has. Wonderful system.
    Monday, October 19, 2015 2:51 PM
  • Why did the setup msi require this
    .NET Framework version v3.5.21022
    ? Was it because .NET Framework 4.5 needs 3.5?



    I can assure you that is not the case. .NET 2.0/3.0/3.5 are one major framework version that is separate and independent of the next major version 4.0/4.5/3.5.1/4.5.2/4.6.

    I suggest that you create a completely new setup project using the VS 2015 tool and see if the new one removes the 3.5 dependency.

    Monday, October 19, 2015 10:16 PM
  • Worked out: the Launch Conditions still specifies .NET framework 3.5. Once I change it to 4.5 problem is solved.
    • Marked as answer by MGA3121 Tuesday, October 20, 2015 9:48 AM
    Tuesday, October 20, 2015 9:48 AM