none
.NET 4.0 Not Installing - Fatal Error RRS feed

  • Question

  • I am trying to install .Net 4.0 but keep getting a fatal error.  I even tried the stand alone version, same results.  Microsoft Messeneger also does not work even that the login box appears when I boot up my computer, some problem relating to Silverlight.  I wouldn't be surprised if this issue is related to that as both programs are Microsoft.  Anyway, help would be appreciated if anyone has some ideas.
    OS Version = 6.1.7600, Platform 2
    [6/19/2011, 20:10:22]OS Description = Windows 7 - x64 Home Premium Edition 
    [6/19/2011, 20:10:22] OS Version Information 
    [6/19/2011, 20:10:22] Environment details: ...
    [6/19/2011, 20:10:22]CommandLine = C:\f5c072c5a61f7891346cdcc01035\\Setup.exe /x86 /x64 /ia64 /web
    - Text removed to make everything fit -
    [6/19/2011, 20:10:34]Starting install of item '.NET Framework 4 Client Profile' at tickCount = 16531769
    [6/19/2011, 20:10:35]C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended.mzz - Signature verified successfully for netfx_Extended.mzz
    [6/19/2011, 20:10:35] C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended.mzz Signature verified successfully for netfx_Extended.mzz
    [6/19/2011, 20:10:35]Signature verification succeeded for netfx_Extended.mzz
    [6/19/2011, 20:10:35]File C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended.mzz, locked for install. 
    [6/19/2011, 20:10:35]Verifying Digital Signatures: C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended.mzz Success
    [6/19/2011, 20:10:35]Verifying Digital Signatures: C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi
    [6/19/2011, 20:10:35] C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi: Verifying signature for netfx_Extended_x64.msi...
    [6/19/2011, 20:10:35]C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi - Signature verified successfully for netfx_Extended_x64.msi
    [6/19/2011, 20:10:35] C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi Signature verified successfully for netfx_Extended_x64.msi
    [6/19/2011, 20:10:35]Signature verification succeeded for netfx_Extended_x64.msi
    [6/19/2011, 20:10:35]File C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi, locked for install. 
    [6/19/2011, 20:10:35]Verifying Digital Signatures: C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Extended_x64.msi Success
    [6/19/2011, 20:10:35]Verifying Digital Signatures: C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe
    [6/19/2011, 20:10:35] C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe: Verifying signature for SetupUtility.exe...
    [6/19/2011, 20:10:35]C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe - Signature verified successfully for SetupUtility.exe
    [6/19/2011, 20:10:35] C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    [6/19/2011, 20:10:35]Signature verification succeeded for SetupUtility.exe
    [6/19/2011, 20:10:35]File C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe, locked for install. 
    [6/19/2011, 20:10:35]Verifying Digital Signatures: C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe Success
    [6/19/2011, 20:10:35] Action complete
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59]returning false
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59]returning false
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59]returning false
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59]returning false
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59]returning false
    [6/19/2011, 20:10:59]evaluating IsPresent:
    [6/19/2011, 20:10:59] Exists: evaluating...
    [6/19/2011, 20:10:59]MsiGetProductInfo with product code {F5B09CFD-F0B2-36AF-8DF4-1DF6B63FC7B4} found no matches
    [6/19/2011, 20:10:59] Exists evaluated to false
    [6/19/2011, 20:10:26]calling PerformAction on an installing performer
    [6/19/2011, 20:10:26] Action: Performing actions on all Items...
    [6/19/2011, 20:10:26]Wait for Item (SetupUtility.exe) to be available
    [6/19/2011, 20:10:27]SetupUtility.exe is now available to install
    [6/19/2011, 20:10:27]Creating new Performer for Exe item
    [6/19/2011, 20:10:27]Created new ExePerformer for Exe item
    [6/19/2011, 20:10:27] Action: Performing Action on Exe at C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe...
    [6/19/2011, 20:10:27]Launching CreateProcess with command line = SetupUtility.exe /aupause
    [6/19/2011, 20:10:28]Exe log file(s) :
    [6/19/2011, 20:10:28]C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt
    [6/19/2011, 20:10:28]Log File C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt exists and will be added to the Watson upload list
    [6/19/2011, 20:10:28]Exe (C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe) succeeded.
    [6/19/2011, 20:10:28]Exe Log File: dd_SetupUtility.txt
    [6/19/2011, 20:10:28] Action complete
    [6/19/2011, 20:10:28]Error 0 is mapped to Custom Error: 
    [6/19/2011, 20:10:28]Wait for Item (clr_optimization_v2.0.50727_32) to be available
    [6/19/2011, 20:10:28]clr_optimization_v2.0.50727_32 is now available to install
    [6/19/2011, 20:10:28]Creating new Performer for ServiceControl item
    [6/19/2011, 20:10:28] Action: ServiceControl - Stop clr_optimization_v2.0.50727_32...
    [6/19/2011, 20:10:28]ServiceControl operation succeeded!
    [6/19/2011, 20:10:28] Action complete
    [6/19/2011, 20:10:28]Error 0 is mapped to Custom Error: 
    [6/19/2011, 20:10:28]Wait for Item (clr_optimization_v2.0.50727_64) to be available
    [6/19/2011, 20:10:28]clr_optimization_v2.0.50727_64 is now available to install
    [6/19/2011, 20:10:28]Creating new Performer for ServiceControl item
    [6/19/2011, 20:10:28] Action: ServiceControl - Stop clr_optimization_v2.0.50727_64...
    [6/19/2011, 20:10:28]ServiceControl operation succeeded!
    [6/19/2011, 20:10:28] Action complete
    [6/19/2011, 20:10:28]Error 0 is mapped to Custom Error: 
    [6/19/2011, 20:10:28]Wait for Item (Windows6.1-KB958488-v6001-x64.msu) to be available
    [6/19/2011, 20:10:28]Windows6.1-KB958488-v6001-x64.msu is now available to install
    [6/19/2011, 20:10:28]Creating new Performer for Exe item
    [6/19/2011, 20:10:28]Created new ExePerformer for Exe item
    [6/19/2011, 20:10:28]WU Service was already enabled or was running
    [6/19/2011, 20:10:28]WU Service: EnsureWUServiceIsNotDisabled succeeded
    [6/19/2011, 20:10:28] Action: Performing Action on Exe at C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu...
    [6/19/2011, 20:10:28]Launching CreateProcess with command line = wusa.exe "C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu" /quiet /norestart
    [6/19/2011, 20:10:32]Exe (C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    [6/19/2011, 20:10:32]PerformOperation on exe returned exit code 2359302 (translates to HRESULT = 0x240006)
    [6/19/2011, 20:10:32] Action complete
    [6/19/2011, 20:10:32]Error 0x240006 is mapped to Custom Error: Success
    [6/19/2011, 20:10:32]Overwrite the current error to S_OK.
    [6/19/2011, 20:10:32]Wait for Item (SetupUtility.exe) to be available
    [6/19/2011, 20:10:32]SetupUtility.exe is now available to install
    [6/19/2011, 20:10:32]Creating new Performer for Exe item
    [6/19/2011, 20:10:32]Created new ExePerformer for Exe item
    [6/19/2011, 20:10:32] Action: Performing Action on Exe at C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe...
    [6/19/2011, 20:10:32]Launching CreateProcess with command line = SetupUtility.exe /screboot
    [6/19/2011, 20:10:32]Exe log file(s) :
    [6/19/2011, 20:10:32]C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt
    [6/19/2011, 20:10:32]Log File C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt exists and will be added to the Watson upload list
    [6/19/2011, 20:10:32]Exe (C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe) succeeded.
    [6/19/2011, 20:10:32]Exe Log File: dd_SetupUtility.txt
    [6/19/2011, 20:10:32] Action complete
    [6/19/2011, 20:10:32]Error 0 is mapped to Custom Error: 
    [6/19/2011, 20:10:32]Wait for Item (netfx_Core.mzz) to be available
    [6/19/2011, 20:10:34]netfx_Core.mzz is now available to install
    [6/19/2011, 20:10:34]Created new DoNothingPerformer for File item
    [6/19/2011, 20:10:34]No CustomError defined for this item.
    [6/19/2011, 20:10:34]Wait for Item (netfx_Core_x64.msi) to be available
    [6/19/2011, 20:10:34]netfx_Core_x64.msi is now available to install
    [6/19/2011, 20:10:34]Creating new Performer for MSI item
    [6/19/2011, 20:10:34] Action: Performing Action on MSI at C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi...
    [6/19/2011, 20:10:34]Log File C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20110619_201023358-MSI_netfx_Core_x64.msi.txt does not yet exist but may do at Watson upload time
    [6/19/2011, 20:10:34]Calling MsiInstallProduct(C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi, EXTUI=1
    [6/19/2011, 20:10:46] Returning IDOK. INSTALLMESSAGE_ERROR [The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.]
    [6/19/2011, 20:10:47]MSI (C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20110619_201023358-MSI_netfx_Core_x64.msi.txt
    [6/19/2011, 20:10:47]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)
    [6/19/2011, 20:10:47] Action complete
    [6/19/2011, 20:10:47]Error 1603:1719 is mapped to Custom Error: Retry
    [6/19/2011, 20:10:47] C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe: Verifying signature for SetupUtility.exe...
    [6/19/2011, 20:10:47]C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe - Signature verified successfully for SetupUtility.exe
    [6/19/2011, 20:10:47] C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    [6/19/2011, 20:10:47]Signature verification succeeded for SetupUtility.exe
    [6/19/2011, 20:10:47]File C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe, is verified successfully. 
    [6/19/2011, 20:10:47]Created new ExePerformer for Exe item
    [6/19/2011, 20:10:47] Action: Performing Action on Exe at C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe...
    [6/19/2011, 20:10:47]Launching CreateProcess with command line = SetupUtility.exe /wireregister
    [6/19/2011, 20:10:47]Exe log file(s) :
    [6/19/2011, 20:10:47]C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt
    [6/19/2011, 20:10:47]Log File C:\Users\Alex\AppData\Local\Temp\dd_SetupUtility.txt exists and will be added to the Watson upload list
    [6/19/2011, 20:10:47]Exe (C:\f5c072c5a61f7891346cdcc01035\SetupUtility.exe) succeeded.
    [6/19/2011, 20:10:47]Exe Log File: dd_SetupUtility.txt
    [6/19/2011, 20:10:47] Action complete
    [6/19/2011, 20:10:47]Helper item execution succeed.
    [6/19/2011, 20:10:47]Delaying for Starting to delay
    [6/19/2011, 20:10:48] Action: Performing Action on MSI at C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi...
    [6/19/2011, 20:10:48]Log File C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20110619_201023358-MSI_netfx_Core_x64.msi.txt exists and will be added to the Watson upload list
    [6/19/2011, 20:10:48]Calling MsiInstallProduct(C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi, EXTUI=1
    [6/19/2011, 20:10:59] Returning IDOK. INSTALLMESSAGE_ERROR [The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.]
    [6/19/2011, 20:10:59]MSI (C:\Users\Alex\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20110619_201023358-MSI_netfx_Core_x64.msi.txt
    [6/19/2011, 20:10:59]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)
    [6/19/2011, 20:10:59] Action complete
    [6/19/2011, 20:10:59]Error 1603:1719 is mapped to Custom Error: Retry
    [6/19/2011, 20:10:59]Retry 1 of 1 of custom error handling
    [6/19/2011, 20:10:59]Retry count over existing limit, not going to retry again.
    [6/19/2011, 20:10:59]OnFailureBehavior for this item is to Rollback.
    [6/19/2011, 20:10:59] Action: Performing actions on all Items...
    [6/19/2011, 20:10:59] Action complete
    [6/19/2011, 20:10:59] Action complete
    [6/19/2011, 20:10:59]Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:36).
    Monday, June 20, 2011 12:34 AM

Answers

  • You can follow the suggestions in the answer in this thread:

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/cbfbec6e-46d7-40a4-8dc9-c3db9515db38

    Except the part about sending logs.

    If you use the log collection tool:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=12493 Running Collect.exe will create vslogs.cab.

    You should upload the resulting vslogs.cab file (found in your %temp% directory) to a public site, like SkyDrive, and post the link here.

    Monday, June 20, 2011 3:50 AM
  • Hi John,

     

    Welcome to the MSDN forum.

     

    According to your post, in my opinion, this issue is possibly related to Windows Installer.

     

    [6/19/2011, 20:10:46] Returning IDOK. INSTALLMESSAGE_ERROR [The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.]

     

    [6/19/2011, 20:10:47]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

     

    The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. This error information was probably caused by that your Windows Installer Service was not started.

     

    Here are two articles I think is helpful:

    http://support.microsoft.com/kb/319624/en-us

    http://www.winhelponline.com/blog/vista-the-windows-installer-service-could-not-be-accessed/

     

    When you intend to reinstall .NET Framework again, here are my suggestions:

    ·         Check if there are any anti-virus or antispyware applications running. Make sure they are turned off during installation.

    ·         Complete or dismiss Windows Updates before installation (but turn on Windows Update service).

    ·         Clean up your “%temp%” folder (Start>>Run>>%temp%)

    ·         Run the setup file with Administrator privileges: Right-click the installer > Run as administrator.

     

    If the problem still exists after these steps, could you please collect the log for me?

    ·         Collect the logs from "%temp%" folder with the Log Collection Tool.

    Collect tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    ·         Send the vslogs.cab file to me (E-mail: v-alsun_at_microsoft_dot_com) or upload it to other website like Windows Live SkyDrive.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Alexander Sun Monday, June 27, 2011 2:36 AM
    Tuesday, June 21, 2011 3:05 AM

All replies

  • You can follow the suggestions in the answer in this thread:

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/cbfbec6e-46d7-40a4-8dc9-c3db9515db38

    Except the part about sending logs.

    If you use the log collection tool:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=12493 Running Collect.exe will create vslogs.cab.

    You should upload the resulting vslogs.cab file (found in your %temp% directory) to a public site, like SkyDrive, and post the link here.

    Monday, June 20, 2011 3:50 AM
  • Hi John,

     

    Welcome to the MSDN forum.

     

    According to your post, in my opinion, this issue is possibly related to Windows Installer.

     

    [6/19/2011, 20:10:46] Returning IDOK. INSTALLMESSAGE_ERROR [The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.]

     

    [6/19/2011, 20:10:47]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

     

    The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. This error information was probably caused by that your Windows Installer Service was not started.

     

    Here are two articles I think is helpful:

    http://support.microsoft.com/kb/319624/en-us

    http://www.winhelponline.com/blog/vista-the-windows-installer-service-could-not-be-accessed/

     

    When you intend to reinstall .NET Framework again, here are my suggestions:

    ·         Check if there are any anti-virus or antispyware applications running. Make sure they are turned off during installation.

    ·         Complete or dismiss Windows Updates before installation (but turn on Windows Update service).

    ·         Clean up your “%temp%” folder (Start>>Run>>%temp%)

    ·         Run the setup file with Administrator privileges: Right-click the installer > Run as administrator.

     

    If the problem still exists after these steps, could you please collect the log for me?

    ·         Collect the logs from "%temp%" folder with the Log Collection Tool.

    Collect tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    ·         Send the vslogs.cab file to me (E-mail: v-alsun_at_microsoft_dot_com) or upload it to other website like Windows Live SkyDrive.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Alexander Sun Monday, June 27, 2011 2:36 AM
    Tuesday, June 21, 2011 3:05 AM
  • Hi John,

     

    Did this help? If you still have any questions about this issue, please feel free to let me know. We will continue to work with you on this issue.

     

    If I have misunderstood anything, please describe your question in more detail and we will be able to provide quicker and better responses.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 23, 2011 2:59 AM