locked
how to disable a Server AUDIT? i keep getting error ---> Disable failed "Lock request time out period exceeded. (MS SQL srvr Error 1222) RRS feed

  • Question

  • every time I enable a server audit in SSMS under Security Audit, I can not disable the audit. I have to shut down SQL services, and restart them and remove the Audit first thing...

    SQL 2008 R2 sp1

    Wednesday, October 12, 2011 8:44 PM

Answers

  • Blue,

     

    Try this:

    - Execute the script to stop auditing

    - Execute: SELECT * FROM sys.sysprocesses where blocked <> 0

    Probably the spid you are using for disable will be blocked, verify the connection that is bloking and kill, if you can...


    Fabrizzio A. Caputo
    Certificações:
    Oracle OCA 11g
    MCITP SQL Server 2008 Implementation and Maintenance
    MCITP SQL Server 2008 Developer
    Blog Pessoal: www.fabrizziocaputo.wordpress.com
    Blog Empresa: www.tripletech.com.br/blog
    Twitter: @FabrizzioCaputo
    Email: fabrizzio.antoniaci@gmail.com
    • Proposed as answer by amber zhang Monday, October 17, 2011 8:42 AM
    • Marked as answer by BlueIzzzz Monday, October 17, 2011 1:49 PM
    • Unmarked as answer by BlueIzzzz Monday, October 17, 2011 1:49 PM
    • Marked as answer by BlueIzzzz Monday, October 17, 2011 1:50 PM
    Thursday, October 13, 2011 6:27 PM

All replies

  • this is under "Server Audit Specification"

     

    If I run a script to disable it, the script runs forever...

    Wednesday, October 12, 2011 8:46 PM
  • Everything time i try to disable the server audit, i get an error msg above... I also tried running a script to disable the server audit, but it runs forever...

     

    Help???

    • Merged by Stephanie Lv Friday, October 14, 2011 1:30 AM duplicated thread
    Wednesday, October 12, 2011 8:52 PM
  • ALTER SERVER AUDIT YourAuditName WITH (STATE = OFF);
    velmurugan.s
    Thursday, October 13, 2011 12:40 PM
  • Blue,

     

    Try this:

    - Execute the script to stop auditing

    - Execute: SELECT * FROM sys.sysprocesses where blocked <> 0

    Probably the spid you are using for disable will be blocked, verify the connection that is bloking and kill, if you can...


    Fabrizzio A. Caputo
    Certificações:
    Oracle OCA 11g
    MCITP SQL Server 2008 Implementation and Maintenance
    MCITP SQL Server 2008 Developer
    Blog Pessoal: www.fabrizziocaputo.wordpress.com
    Blog Empresa: www.tripletech.com.br/blog
    Twitter: @FabrizzioCaputo
    Email: fabrizzio.antoniaci@gmail.com
    • Proposed as answer by amber zhang Monday, October 17, 2011 8:42 AM
    • Marked as answer by BlueIzzzz Monday, October 17, 2011 1:49 PM
    • Unmarked as answer by BlueIzzzz Monday, October 17, 2011 1:49 PM
    • Marked as answer by BlueIzzzz Monday, October 17, 2011 1:50 PM
    Thursday, October 13, 2011 6:27 PM
  • This really doesn't answer the problem. Anyone have any more information. I get the same error and can only bounce the server to corret it.


    JB

    Monday, April 16, 2012 12:57 PM