none
Windows Embedded Standard 7 USB Video issue RRS feed

  • Question

  • Dear all,

    I have installed WES7 P with the template application compatibility. I have also install manually with DISM tool following packages : 

    - X86~winemb-inf-usbcir

    - X86~winemb-inf-usbvideo

    -X86~winemb-inf-wdma_usb

    - X86~winemb-inf-wdmaudio

    - X86~winemb-inf-winusb

     

    And I have plugged microsoft lifecam studio HD webcam. webcam is recognized and installed successfully (on device manager it is ok) but when I try to use it, players cannot succeed in connecting the webcam.

    Another issue comes from a usb Hub that is not recognized. When I plug USB key  directly behind the PC it's ok. When I try to connect it behind the USB Hub it doesn't recognize it.

    Any suggestion to help me ?
    Thanks in advance,

    best regards,

     

    Luke 

     

    Wednesday, September 7, 2011 8:49 AM

All replies

  • You might be missing a driver package. Did you install Windows 7 on the target system with all of the drivers, run TAP to capture all the driver PnP IDs in a PMQ file, and then import the PMQ into the answer file?

     

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Wednesday, September 7, 2011 3:30 PM
    Moderator
  • Many Thanks Sean for your answer.

    I agree with you, It might be missing drivers. I don't know how to install all drivers. I've just install windows7 on the target system choosing template application compatibility + the 4 drivers packages.

    Do you know a  procedure to install all drivers packages ?

    Thanks in advance,

    best regards,

     

    Luc. 

    Thursday, September 8, 2011 7:05 AM
  • Check the dependencies of the DISM installed packages via ICE. There might be a missing component.

    Regards

    Thursday, September 8, 2011 11:24 AM
  • it seems he really missed to integrate the drivers for the cam.

    you also could try to get the drivers via Windows Update. Does the RuntimeImage have a Internet Connection online?!
    "Mark/Propose As Answer" if you got one.
    Thursday, September 8, 2011 12:35 PM