none
Regarding USBCV tests in 3.0 RRS feed

  • Question

  • Hi,

     I am running the HCK tests for Windows server 2012/Windows 8 certification and except for the USB-IF certification validation test, all other tests have been completed. When I ran the USB-IF test using USBCV log generated using USBCV 2.0, I noticed that I have to generate log files using USBCV 3.0 and hence downloaded and installed USBCV 3.0 in the system. Following is what I did:

    1. Installed USBCV 3.0 in a server 2012 system.

    2. Disabled UAC and rebooted

    3. Copied the usb.if file to lib\ folder.

    4. Started the USBCV tool and ran the usb 2.0 as well as 3.0 tests. But what I noticed was that in both scenarios, the test suite initialization failed with following error:

    "Error getting a new Slot from Host Controller.
    Couldn't initialize common subsystems."

    Have I missed anything which could cause this error? I checked the device manager to make sure that the stack switch has happened. So, that is not the issue. Also, one more thing I noticed was that the device under test is not enumerated anywhere after stack switch. Is it an issue?


    Janardhanan.R.

    Wednesday, March 13, 2013 10:45 AM

All replies

  • Hi Janardhanan,

    You are correct in running the USB30CV, that is the one required for WHCK device certification.  However I would recommend installing and running the tool on a client SKU rather than server.  We've validated the latest USB30CV tool run properly on the Windows 8 client with a known good xHCI controller.  The USB-IF tests need only be run once on one operating system, and the results (in the form of log files) can be applied to all OS submissions for the device under test.

    Also you may want to try a different USB 3.0 controller, there are some buggy controllers that may be causing the error you are seeing.  The WHCK help documentation recommends the following controllers: Renesas Electronics 200, 200A, 201/202 and Fresco Logic 1009, 1100.  Any controller that is both USB-IF and WHCK certified should be sufficient.

    Your observation that the device doesn't show up as enumerated after the stack switch is correct and expected.  The USB30CV test loads a custom test driver on the xHCI controller and doesn't enumerate the child devices to PnP so they don't appear in the device driver.

    Best Regards,

    Philip Froese,

    USB Team, Microsoft

    Friday, March 15, 2013 7:52 PM
  • Hi Philip,

      Thanks for the reply. I tried the same in Win 8 64-bit system too but got the same result. Following are my controller details:

               Renesas USB 3.0 eXtensible Host Controller - 0100
               vendor id 1912 product id 0015

      Should I try with some different controller to achieve the expected results? All other USB tests have succeeded except for this one.

       Regards,

    Janardhanan.R.

     


    Janardhanan.R.

    Monday, March 18, 2013 7:17 AM