none
Service Fabric Cluster stuck "Deploying" or showing nodes not available RRS feed

  • Question

  • I have made multiple attempts, with multiple configurations, to get a SF cluster to deploy and have had zero success.

    Every attempt gets stuck in "Deploying" or "Baseline upgrade" and I am not able see the nodes in Azure Resource Manager or Service Fabric Explorer. My latest attempt is stuck in "Deploying" but that is uncommon, usually they get stuck in "Baseline upgrade". In the resource group I can see the various pieces are created.

    I am typically able to see that the nodes are created in the resource group along with all the other things such as load balancer, scale set and virtual network.

    I have tried various things with certificates (creating one during cluster configuration, and creating one before-hand and using "Custom" during cluster configuration). I have tried adding one for the Admin client. I've tried creating a network security group and assigned it to the subnet. I have even created a nsg with ALL ports open for inbound and outbound assigned to the subnet.

    Have tried both East US and East US2. Using instance size B1s.

    Have read through and tried everything I can find online about this situation and so far, haven't found the tip that solves it for me.

    I'm not trying to create anything fancy here, a simple 1, 3 or 5 node cluster will do - working on my first one and first integration from Microsoft DevOps. Been stuck here since last Wednesday.

    Regarding DevOps, suspecting a certificate issue to the cluster, on a few of my attempts I have tried to release to the cluster and it always gets stuck in "Uploading to package store", which also seems to point to a security issue. But what?

    As far as I can tell, I am doing all the things I am supposed to do with the cert, and using the correct values in the proper places.

    Any help would be great!

    Will

    Monday, April 29, 2019 11:44 AM

All replies

  • Hi Will, are you following any specific documentation to deploy the cluster? If so, can you please share? I can go through the same steps and see if there is anything blocking
    Monday, April 29, 2019 4:26 PM
    Moderator
  • Any update on this issue? 
    Friday, May 3, 2019 7:10 PM
    Moderator
  • I'm having the exact same issue.

    I created the resource group and key vault first, in UK south.

    I then followed the service fabric wizard, choosing the B1s, 1 node group etc.

    The virtual machine scale set is all there. All 5 instances are running fine.

    The networking, LB, subnet etc is all there.

    In my final attempt it is stuck in "deploying" after 12 hours. Previous attempts said "waiting for nodes".

    No nodes are shown on the fabric overview page.

    Can anyone help please?



    MikeM

    Friday, May 24, 2019 6:41 AM
  • This seems related to minimum VM requirements and disk space. The wizard seems to let you pick any size, but there seems to be a minimum you need to manually select.

    We chose "Standard_D1_v2 (5 instances)" which seems to work. Anything below this and it hangs.

    MikeM

    Thursday, July 4, 2019 11:19 AM