none
Word 2013 - Bulleted list inside rich text content control RRS feed

  • Question

  • Hi,

    I'm mapping a rich text content control to an xml node within my custom xml.

    While i'm in design mode i try to format the text so that it will be a numbered list.

    One thing that i noted though was that the numbers are placed outside the content control. This is only my first observation.

    The thing is, the rich text(RTF) that is saved within the custom xml is later used to populate a second document. This works great except for one small issue. The numbered list is not showing up within the second document.

    Would appreciate any help i can get with this issue.

    Br,

    /Peter


    Peter

    Wednesday, July 2, 2014 11:20 AM

Answers

  • Hi Peter

    This is tricky, because...

    By default, when you insert a new RichText content control it will not include the paragraph mark for the paragraph it's in. Numbering is a paragraph-level formatting.

    If you work in Word, you can see this. Turn  on the display of non-printing characters (the backwards P button in the "Home" tab of the Ribbon). Insert a RT content control and observe where the paragraph mark (backwards P) is in relation to the CC's boundaries. Now press ENTER and observe that the paragraph mark is WITHIN the CC. Apply number formatting and you'll see that it's NOW inside the CC.

    You can do this the other way around: apply the numbering then press ENTER. Again, it should now be within the CC.

    This behavior is by-design. I would guess that lists the users type would have more than entry, so the numbering will be within the CC range when the custom XML is extracted?


    Cindy Meister, VSTO/Word MVP, my blog

    Wednesday, July 2, 2014 2:52 PM
    Moderator

All replies

  • Hi Peter

    This is tricky, because...

    By default, when you insert a new RichText content control it will not include the paragraph mark for the paragraph it's in. Numbering is a paragraph-level formatting.

    If you work in Word, you can see this. Turn  on the display of non-printing characters (the backwards P button in the "Home" tab of the Ribbon). Insert a RT content control and observe where the paragraph mark (backwards P) is in relation to the CC's boundaries. Now press ENTER and observe that the paragraph mark is WITHIN the CC. Apply number formatting and you'll see that it's NOW inside the CC.

    You can do this the other way around: apply the numbering then press ENTER. Again, it should now be within the CC.

    This behavior is by-design. I would guess that lists the users type would have more than entry, so the numbering will be within the CC range when the custom XML is extracted?


    Cindy Meister, VSTO/Word MVP, my blog

    Wednesday, July 2, 2014 2:52 PM
    Moderator
  • Hi Cindy,

    Thanks a lot! Not that obvious :-)

    Altough, the text within the content control is a heading so i do not like the fact that you need to add an extra ENTER. However, i think i can play around with font size so i do not mess up the layout too much =P

    Again, thanks!

    Br,

    /Peter


    Peter

    Wednesday, July 2, 2014 4:58 PM
  • Hi Cindy

    I have a similar problem. I am using Word 2013 to create a form for a Safety Procedure for our company. I have used the Rich Text Content Control (RTCC) objects throughout my template file. I have set up restrictions for 'filling in forms'. I have also gone into my Rich Text Content Controls and put in a paragraph marker (backwards P). If I haven't started Enforcing Protection I can add bullet points, numbering, and a few other options into my RTCC, but as soon as I Start Enforcing Protection by entering a password all those Ribbon controls for adding new content to within my RTCC are disabled.

    How can I maintain restricted input access to the RTCC's but enable the user to use many of the controls on the Word Ribbon on the Home tab? The user has requested they want to enter bullet points, numbering, smart art, etc. into the RTCC. Is this possible once the Enforce Protection is enabled?

    Thanks very much. Michael

    Friday, March 6, 2015 4:24 AM
  • Michael,

    Did you ever find the solution to this?

    MM

    Thursday, October 3, 2019 1:55 PM