none
CTK Authentication Matrix Test - apcontol.exe Exception RRS feed

  • Question

  • Hi,

    I am running the CTK Wi-Fi Authentication Matrix test on a Windows Embedded Compact 7 Device.

    I have a Wi-Fi Metrics setup and I've run this test many times on CE 6 Devices. For the new CTK I just replaced the NT binaries on the Authentication Server with the new ones in the CTK test kit. The Server is a Windows Server 2003 Standard (32bit) box and has been setup following the wifimetric_ctk.docx. I get the following when I launch apcontrol.exe from the NT directory:

     

    \NT>apcontrol -debug

    10:08:54 00000630: Log created at 10:08:54.421 on 01/12/2012

    10:08:54 00000630: APControl Msg: Running: apcontrol -debug

    10:08:54 00000630: APControl Dbg: RegistryAPPool::LoadAPControllers("Software\Microsoft\CETest\APCTL")

    10:08:54 00000630: APControl Dbg: Reading AP 0

    10:08:54 00000630: APControl Dbg: CreateConfigurator("Software\Microsoft\CETest\APCTL\AP0")

    *** FATAL ERROR *** Exception in mymain10:08:54 00000630: APControl Time to complete test: 00:00:00 total milliseconds: 31

    10:08:54 00000630: APControl The test PASSED with 0 errors and 0 warnings

    10:08:54 00000630: APControl @@@@@@0

    10:08:54 00000630: Log ended at 10:08:54.437 on 01/12/2012

    I have tried many different AP0 reg. settings and always get the fatal exception in "mymain". If I roll back to CE 6 binaries the server launches correctly but the CTK 7 client binaries are different and the test doesn't run properly.

    Is the apcontrol.exe binary included in the test kit functional? 

     

     

     

    Thursday, January 12, 2012 5:03 PM