locked
DateTime field value cannot handle blank/null RRS feed

  • Question

  • I have added a new Field Definition of type DateTime to the 'Bug' work item type.
    I then added this field to the layout - new control and type set to DateTimeControl.

    When I open Web Access for an existing bug the field is blank (which is perfect).
    If I select a  date in datetimepicker and saves, then all works fine.
    If I open the same on and deleted the date (blank in the textbox) it saves as '1899-dec-30'.

    Read somewhere that SP1 should fix this but it doesn't for me. Running:

    Microsoft Visual Studio 2008 Team System Web Access SP1

    Version 9.0.3160.19504


    How can I set this date back to Null in Web Access?

    Regards
    Lovsten


    ML
    Tuesday, December 2, 2008 12:46 PM

Answers

  • Hi Magnus,

    This is a known bug and fixed, but the fix will be available for the next release. Sorry for the inconvenience.

    Regards
    Serkan Inci - MSFT
    • Proposed as answer by Bill.Wang Friday, December 5, 2008 3:49 AM
    • Marked as answer by Bill.Wang Monday, December 8, 2008 3:11 AM
    Thursday, December 4, 2008 8:13 PM

All replies

  • Hi Magnus
     

    I haven't find that this issue is logged. It seems there's no way to set a date time field to null in TSWA. :( Could you help to file this issues to Visual Studio Connect? In the future, we will migrate Connect to this forum platform. But before the migration, we will continue to use Connect to file feedbacks. Thanks for your help.


    Please mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, December 4, 2008 7:27 AM
  • Hi Magnus,

    This is a known bug and fixed, but the fix will be available for the next release. Sorry for the inconvenience.

    Regards
    Serkan Inci - MSFT
    • Proposed as answer by Bill.Wang Friday, December 5, 2008 3:49 AM
    • Marked as answer by Bill.Wang Monday, December 8, 2008 3:11 AM
    Thursday, December 4, 2008 8:13 PM