none
XAML Designer Error saying Package deployment blocked

    Question

  • Whenever I develop a Windows Universal App, I get this error when I try to design my pages. As a result, I could not use IntelliSense in XAML editor (i can still IntelliSense in code editor though) and I could not use the property window to edit properties of controls. I already tried to increment the Build number but still no result.

    System.Exception

    The provided package is already installed, and reinstallation of the package was blocked. Check the AppXDeployment-Server event log for details. (Exception from HRESULT: 0x80073CFB)

    I am doing this on

    Windows 10 November Update

    Visual Studio 2015 Community Edition

    • Edited by MarkIvanDev Wednesday, November 25, 2015 10:40 AM
    Wednesday, November 25, 2015 10:38 AM

Answers

  • Hi MarklvanDev,

    I also use Visual Studio 2015 Community with Update 1 RC on Windows 10 with November Update, and the XAML Designer works fine. Please check whether you have install the Update 1 RC for your Visual Studio 2015 first.

    Is this problem occurs after installing Visual Studio 2015 Community or using some time? If occurs after installing, please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    If occurs when using some time, please try with following steps to troubleshoot this problem.

    1. Check the settings for XAML Designer as below shows in menu Tools -> Options. Please make sure you have enable XAML Designer.
    2. Run Visual Studio 2015 in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software when running Visual Studio, such as antivirus software.
    4. Reset all setting through the menu of Tools -> Import and Export settings -> Reset all settings.
    5. Repair your Visual Studio.

    Best Regards,
    Weiwei

    Thursday, November 26, 2015 6:14 AM
    Moderator