locked
Can't publish app with Indie License. RRS feed

  • Question

  • User16119 posted

    Hi, I'm trying to publish a demo app to Google Play and i have an indie license. When trying to "Publish Android Application..." it just keeps giving me the error "Bundling assemblies requires a Enterprise license. Even though i have unchecked that checkbox under Release configuration in the Project Options. I've even tried to activate the trial license that it offers me, but no change there. I really need to get this thing up there to show a client to see where we go from here.

    Monday, August 5, 2013 7:59 AM

All replies

  • User16119 posted

    I'm using the Azure Mobile Services component. Could it be that i need an Enterprise license to publish using that to Google Play?

    Monday, August 5, 2013 8:22 AM
  • User13824 posted

    Sounds like this could be a bug. Just to check quickly, your project settings look like the attached image, correct?

    Also:

    1. Are you using the latest versions of Xamarin ("Xamarin Studio -> Check for Updates" on Mac, "Help -> Check for Updates" on Windows)?
    2. Does "Publish Android Application..." succeed for other projects? For example, does it work for a brand new Android project?
    3. It sounds like the error happens before the Keystore selection dialog appears, true?
    4. As a temporary work-around, maybe the old, manual Visual Studio signing method will work?
    Tuesday, August 6, 2013 1:20 AM
  • User16119 posted

    Thanks for your reply Brendan. I haven't tried any other projekt. That is a good first move of course. It does happen after the keystore selection dialog. It halts on line 1203 in the Xamarin.Android.Common.target file with the above error.

    I tried with the Tasky project and that worked fine. That project didn't have any Android specific options though it seemed. When going into the Project menu and then selecting the solution options at the bottom of the menu. It didn't look the same as my current project for some reason. Under the "Build" menu to the left when opening up the solution options it didn't have "Android Build" and Android Application".

    Tuesday, August 6, 2013 3:25 PM
  • User16119 posted

    Not the solution options, but the Project Options at the bottom of the menu, just to clarify.

    Tuesday, August 6, 2013 3:26 PM
  • User16119 posted

    Oh, my bad. It does have the same options.

    Tuesday, August 6, 2013 3:28 PM
  • User16119 posted

    Eh, seriously, now those options are gone again...:O

    And i just found the place to Edit a post, sorry for the multiple postings.

    I added some references to the Azure MobileServices API as well and added it to Components, and that still works for Tasky, so it doesn't seem to have anything to do with that. And i'm signing Tasky with the same keystore as my other app.

    And yes, i'm using the latest version. Updated a few days ago.

    Tuesday, August 6, 2013 3:29 PM
  • User16119 posted

    Since i only have the Indie license i can't use my project in Visual Studio.

    Tuesday, August 6, 2013 4:37 PM
  • User13824 posted

    Hmm strange. Since Tasky is working, maybe something funny happened to the project file? Perhaps you can fix it by creating a fresh project, and adding all the files to it. If that fixes the problem, and you wouldn't mind attaching the old and new .csproj files (or e-mailing them to support@xamarin.com), that would be great.

    The "Visual Studio" signing method will work on Xamarin Studio too, as long as "Project -> Create Android Package" works (I think). The idea is to take the unsigned output package and do the final keystore signing by hand on the command line.

    Tuesday, August 6, 2013 7:14 PM
  • User16119 posted

    Ok, i found the solution finally. I had to manually remove the setting to Bundle Assemblies from the csproj-file. It didn't work to remove the setting from the options using the gui. I don't know if the reason it didn't work from the gui was that a window popped up telling me that i needed the Enterprise license to bundle assemblies. And asked if i wanted a trial or upgrade my license. If i there pressed cancel it unchecked that option for me in the gui, but it doesn't seem to actually have changed that setting. It doesn't seem to sign and zipalign however, is it supposed to do that automatically? I can do it manually, so it's not a showstopper, but i got the impression that those things were supposed to be automatic now as well. But now it works. Thanks for your help Brendan, much appreciated.

    Wednesday, August 7, 2013 8:56 AM
  • User13824 posted

    Nice work finding the csproj "Bundle Assemblies" work-around! I was able to reproduce that problem too, so I filed a bug for it: https://bugzilla.xamarin.com/show_bug.cgi?id=13829

    It doesn't seem to sign and zipalign however, is it supposed to do that automatically?

    Yes, when I try it, "Publish Android Application..." does produce a keystore-signed, zipaligned APK file. "Create Android Package..." produces a zipaligned APK file, signed with the debug certificate.

    Wednesday, August 7, 2013 7:19 PM
  • User16119 posted

    Great. When i do Publish Android Application and then upload the file to Google Play it tells me it's not zipaligned, and when i do that manually it tells me it's not signed. But it's all good, it's not a problem really. I'll look into it a little bit more later on.

    Wednesday, August 7, 2013 8:23 PM
  • User13824 posted

    Sounds good.

    Friday, August 9, 2013 3:29 PM