Adobe Reader Application Failure When Attempting to Print RRS feed

  • Question

  • Have Adobe Reader X 10.1.1 installed to view PDF files.  Printing under Windows 8 has worked fine since installed but recently attempts to print result in the following error:

    AcroRead32.exe - Application Error

    The exception Integer division by zero.

    (0xc0000094) occurred in the application at location 0x5956a6bb.

    Click OK to terminate the program.

    I have restarted Windows 8 and have repaired the Adobe application package without success.  The specific PDF or source of the PDF file is irrelevant.  Please note that screenshot could not be pasted in the thread.





    • Edited by KLawson419 Sunday, October 2, 2011 8:58 PM
    Sunday, October 2, 2011 8:52 PM


All replies

  • KLawson419,

    Are you getting the error message after you click on "OK" button to send print queue to printer or before where you are in Print dialog where you can make changes to settings like choose different printer or select Print Range?

    Monday, October 3, 2011 7:43 PM
  • //
    // MessageText:
    // {EXCEPTION}
    // Integer division by zero.

    The Acrobat Reader has a bug and tries to divide by zero. The reader sucks, use Sumatra PDF instead:


    "A programmer is just a tool which converts caffeine into code"

    Monday, October 3, 2011 8:20 PM
  • The error occurs as soon as you select Print from the File menu (waiting for the Print dialog box to be displayed) or clicking on the Printer icon.
    Tuesday, October 4, 2011 12:22 AM
  • Andre,

    Thanks for the feedback.  For my personal use, I will check out Sumatra.

    Tuesday, October 4, 2011 12:24 AM
  • KLawson419,

    Did Windows Developer Preview installed your printer drivers or you got download and install the printer drivers from manufacturer website?

    Tuesday, October 4, 2011 1:09 PM
  • I am using the print drivers installed by Windows Developer Preview.  As indicated in original post, printing seemed to work fine upon initial installation of Windows Developer Preview and Acrobat Reader.  In checking the Windows 8 Installed updates list, Adobe was updated on 9/17/2011 and Windows 8 was updated on 9/19/2011.  I can not confirm whether the print function worked on 9/17 or 9/18.
    Tuesday, October 4, 2011 3:41 PM
  • KLawson419,

    What is your make and model of your printer?  Go ahead and use manufacturer drivers instead and see if that fix the issue.  You might need to use Compatibility mode to get it install.  Here is steps to run Compatibility mode.

    1. Right click on setup file
    2. Click on Properties
    3. Click on Compatibility tab
    4. Put a check mark on Run this program in compatibility mode for:
    5. Select Windows 7
    6. Put a check mark on Run this program as an administrator under Privilege Level 
    Tuesday, October 4, 2011 4:09 PM
  • I have the same problem. It does not seem to be printer driver related as this happened before I even installed printers and it only happens in Adobe all other apps work fine. I have since installed printers and everything works accept adobe reader.
    Tuesday, October 4, 2011 7:00 PM
  • KLawson419 and qdewolf,

    Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here

    In case the link above gets messed up, the URL is below:


    The last link goes to: How do I install the Windows Feedback Tool and file a bug

    Tuesday, October 4, 2011 7:43 PM
  • Printer is an HP Photosmart 2710.  I also do not believe that this is a printer driver issue as printing works fine for all other applications.  See reply later regarding additional testing.
    Wednesday, October 5, 2011 1:16 AM
  • Based on Eric's reply earlier about trying manufacturer's printer driver, I performed further testing.  I am reluctant to install manufacturer's printer drivers since all other application printing is fine.  I did however, try setting compatibility mode on Acrobat Reader since printing does work fine in Windows 7.  I was able to get Adobe Reader printing to work properly by setting Compatibility Mode on Acrobat Reader to Windows XP/SP 3 after running the Windows Compatibility Troubleshooter.  I tried turning off Windows Compatibility Mode and retested still failed.  Through several other permutations of setting mode directly on the executable rather than the shortcut in Start Menu, I was ultimately able to remove the Compatibility Mode check and now Adobe Reader is working in Windows 8 mode without checking Compatibility Mode.
    Wednesday, October 5, 2011 1:29 AM
  • what did you change? is compatibility still on for the reader app?
    Wednesday, October 5, 2011 6:43 PM
  • At first I did a right click from the 'start menu', advanced, and selected open file location - the path is: "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Adobe Reader X.lnk".  I selected the Compatibility TAB and tried Windows 7, then Vista (Service Pack 2).  Neither made any difference.  I then tried the Compatibility Troubleshooter.  The end result was Windows XP (Service Pack 3) which resolved the issue.  I reverted back to unselect the Run in Compatibility mode and it failed.   I went to the EXE located at: "C:\Program Files\Adobe\Reader 10.0\Reader\AcroRd32.exe" and tried Windows XP (SP 3) Compatibility and without Compatibility set and the application worked fine.  I tried several other things including one which probably wasn't a good test but I found the EXE in my Windows 7 environment (dual boot PC) and started Adobe by double clicking the Windows 7 EXE and tested. It worked without Compatibility mode being set.  I finally rebooted and retested both environments - Windows 7 to insure that I didn't mess anything up and also Windows 8.  Now the application is working fine WITHOUT Compatibility being set. 
    Wednesday, October 5, 2011 7:54 PM
  • I went to the C:\Program Files\Adobe\Reader 10.0\Reader\AcroRd32.exe and changed the Security Settings adding authenticated users with full rights, and opened a pdf file (when opennig Acrobat asked if want to disable the proectded mode i said yes ) since then i do not have any Errors .
    Thursday, February 2, 2012 8:36 PM
  • hsap

    I tried your suggestion without success - I still got the division by zero error.  I did go back and change compatibility to Windows XP (SP 3) and the problem no longer appears.  What a great product - Adobe.... 

    Thursday, February 2, 2012 9:27 PM
  • I've disabled Reader's Protected Mode and Adobe Reader doesn't crash when I click Print.


    • Edited by davidetadz Friday, February 3, 2012 2:01 PM
    • Marked as answer by KLawson419 Friday, February 3, 2012 2:46 PM
    Friday, February 3, 2012 1:59 PM