none
JSON Outline tool not appearing in VS 2015 or 2017

    Question

  • When I open a JSON ARM file the outline does not appear in the Cloud Explorer window. I also do not get intellisense for the template. Here is the file

    {
      "$schema": "http://schema.management.azure.com/schemas/2015-01-01/deploymentTemplate.json#",
      "contentVersion": "1.0.0.0",
      "parameters": {
    
      },
      "variables": {
    
      },
      "resources": [
    
      ],
      "outputs": {
    
      }
    }
    

    Tuesday, April 11, 2017 8:53 PM

Answers

All replies

  • I fixed it by removing Azure SDK 3.0 and going back to 2.9(November 2016)
    Tuesday, April 11, 2017 10:13 PM
  • Hi aalang,

    Welcome to MSDN forum.

    Glad to know that you have solved the issue by yourself and thank you for sharing the solution here. could you please mark your reply as an answer which will be helpful for those who has the similar issue with you? Thank you for understanding.

    I test it in my side, i could open the JSON outline windows by click view->other windows, please see the screenshot:


     Besides, click Tools->Options->Text editor, refer the following screenshots:

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, April 12, 2017 4:58 AM