none
windows service and timer to kill other process RRS feed

  • Question

  • Dear Sir

    I have developed a windows service and Timer to klll some process that we want to restrict the users to use. Its working perfectly in debugging mode but not independently. I don't know what to do., may be some rights problem but I tried as admin. local machine, local service etc. . . . nothing happened/no response when executed but perfect in debugging. 

    Regards

    Chand Mohammad

     

    Friday, April 11, 2014 11:31 AM

Answers

  • With services, you'll want to log results, particularly failures and security/authentication issues.  Probably in the application event log (as in: the one that you view with the Event Viewer).

    I'm fairly confident your actual problem would be related to privileges/security.

    I think you need the SeDebugPrivilege to terminate arbitrary processes.

    Friday, April 11, 2014 3:26 PM

All replies

  • Dear sir

    I have developed a windows service , which uses a timer to kill some other programs available in the database list. When service is executed in debugging mode, it perfect and kills all selected process but when run independently, it do not kill the same selected process. I am not getting why this is so. The process selected to kill are general software that we do not want the user to start.

    Regards

    Friday, April 11, 2014 10:35 AM
  • With services, you'll want to log results, particularly failures and security/authentication issues.  Probably in the application event log (as in: the one that you view with the Event Viewer).

    I'm fairly confident your actual problem would be related to privileges/security.

    I think you need the SeDebugPrivilege to terminate arbitrary processes.

    Friday, April 11, 2014 3:26 PM