locked
"The OutputPath property is not set for this project"... RRS feed

  • Question

  • User1655708501 posted

    I have a solution with 7 projects; 1 website, 1 WDP, 5 class libraries.

    I want to set up solution configurations to deploy in different, well, configurations.  So Debug, Staging.DevDB, Staging.LiveDB, Release.  The WDP mirrors the solution configuration.  The class libraries have only Debug and Release configurations (since Staging.* would just be copies of Debug, and I don't want to have to remember to set up the projects individually each time I add a new one).

    When I build my solution in Debug or Release, it builds fine.  When I build in Staging.*, it the WDP errors out with the following error message (one for each class library):

    The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration='Staging.DevDB'  Platform='AnyCPU'

    Why?  And, more importantly, how do I fix or work around it?  I do _not_ want to have to create copies of configurations.

    Thursday, October 12, 2006 7:17 AM

All replies

  • User-2110989382 posted

    I've experienced the exact same problem. Have you tried manually editing the .wdproj file? I've had to do quite a bit of editing in there to make the all the post build events I needed work. You should sue a <propertygroup> for each build config and a <outputPath> statement in each property group.

    The only workaround that I have tried and had any success with thus far has been to edit all of the .proj files to remove the entries that aren't working. I'm still getting some strange results when I do post build events, like copying files to folders that shouldn't be created/exist because the build config has been removed etc.

     I think this is actually a bug in the WD Project type. Hopefully some of this will be fixed by SP1..?

    Monday, October 30, 2006 1:48 PM
  • User1075093880 posted
    I am also having the exact same problem.  Good to know I'm not the only one.  I am still without a workaround though, so please post any solutions/workarounds you come up with.
    Tuesday, November 14, 2006 11:57 AM
  • User-953341719 posted

    What are other possible causes of this error message if, having looked through the property dialog AND the actual project XML file itself there are infact NO missing OutptPath properties and they exist for ALL build configs and platforms?

     

    Specifically, in addition to Debug and Release, I have "Demo Release" and "Test Release" build configs. At one time these worked. Then at some point (I believe when I added a new library project), they stopped working (the Debug and Release configs never stopped working). No amount of hiding the new project and/or trying to emulate the original environment has gotten the Demo Release and Test Release configs to build again. They always give this error message.

    Tuesday, November 14, 2006 5:28 PM
  • User-953341719 posted
    Okay then, so the eventual solution was to open up my SLN file as raw text and hack around a bit. I was able to get the new builds to work again as there seemed to be some entries missing in a funky-looking section where there were aliases for various build/platform combos. I still don't fully understand what happened, and I can't correlate what I changed in the SLN file back to what you can edit in the build configurations dialog in Visual Studio.
    Wednesday, November 15, 2006 1:07 PM
  • User1108651750 posted

    Can you (or anyone else) elaborate on what fixed this problem.

     I also just tried adding a WDP and have added some configurations "Testing_Debug", "Testing_NoDebug" among a couple others.  I edited my SLN file in ASCII and saw a section where multiple lines containing what appears to be the solution's projects identified by a GUID followed by the permutations of project configurations and platforms all equated to a short form of the config & platform.  Like this...

      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Debug|.NET.ActiveCfg = Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Debug|Any CPU.Build.0 = Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Debug|Mixed Platforms.ActiveCfg = Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Production|.NET.ActiveCfg = Production|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Production|Any CPU.ActiveCfg = Production|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Production|Any CPU.Build.0 = Production|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Production|Mixed Platforms.ActiveCfg = Production|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Production|Mixed Platforms.Build.0 = Production|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Release|.NET.ActiveCfg = Release|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Release|Any CPU.ActiveCfg = Release|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Release|Any CPU.Build.0 = Release|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Release|Mixed Platforms.ActiveCfg = Release|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Staging|.NET.ActiveCfg = Staging|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Staging|Any CPU.ActiveCfg = Staging|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Staging|Any CPU.Build.0 = Staging|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Staging|Mixed Platforms.ActiveCfg = Staging|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Staging|Mixed Platforms.Build.0 = Staging|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|.NET.ActiveCfg = Debug|.NET
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|.NET.Build.0 = Testing_Debug|.NET
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|Any CPU.ActiveCfg = Testing_Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|Any CPU.Build.0 = Testing_Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|Mixed Platforms.ActiveCfg = Debug|Mixed Platforms
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_Debug|Mixed Platforms.Build.0 = Debug|Mixed Platforms
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_NoDebug|.NET.ActiveCfg = Testing_NoDebug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_NoDebug|Any CPU.ActiveCfg = Testing_NoDebug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_NoDebug|Any CPU.Build.0 = Testing_NoDebug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_NoDebug|Mixed Platforms.ActiveCfg = Debug|Any CPU
      {1C4CD750-C307-4D3B-8612-8A9511EE2C1B}.Testing_NoDebug|Mixed Platforms.Build.0 = Debug|Any CPU

    The lines bolded above don't seem to follow the rules of the entries.  I tried changing them so that the configuration name on the right hand side of the equal sign was the same as that on the left.  This didn't solve the problem - still get the OutputPath property error on build.

    Help!

     

    Tuesday, November 21, 2006 9:05 PM
  • User1398525513 posted
    Has this been filed as a bug yet, or any progress made on resolving it?
    Thursday, March 1, 2007 1:44 PM
  • User-1790338175 posted
    The easiest way to fix this problem is by opening up the raw text of the .wdproj file and then searching for the text like:

    <OutputPath>.\Release\</OutputPath>

    And make sure that you remove the additional slash after the folder name.

    Hope this helps!

    Thursday, March 15, 2007 3:09 PM
  • User1274337811 posted

    Matthew, unfortunately that doesn't seem to solve the problem. I agree that it's easy though :-)

    Has anyone figured out a definitive solution to this? I've just encountered this problem too and it's driving me nuts.

     

    Jason

     

    Thursday, May 10, 2007 11:53 AM
  • User1274337811 posted

    I thought I should provide a bit more detail, partly to "bump" this thread a little and partly to increase the chances of getting a response. Looking at the number of views for this thread, I guess there are other people looking for an answer to this issue too!

    I had a VS2003 solution, containing one Web project and one Custom control project. I converted this to a VS2005 solution, containing one Web Site project and one Custom control project.

    I then discovered the whole deployment issue several days later, and so created a Web Deployment project. I followed the instructions ( http://msdn.microsoft.com/en-us/library/aa479568.aspx ) exactly. When I came to build my Web Deployment project, however, I get the error message "The OutputPath property is not set for this project".

    I've checked the OutputPath properties. They're all there. I've tried building several different configurations, none of them work. I've tried Matthew's suggestion of removing the trailing slash from the OutputPath, and that didn't work either.

    Can anybody suggest how I can get around this problem? I'm minded to give up on Web Deployment projects entirely, and make a Web Application project instead, but that will take even more time...

     

    Thanks

     

     

    Jason

     

    Monday, May 14, 2007 4:04 AM
  • User-42907567 posted

    Hi hi !

    Well, i was having the same problem and i found the solution just now *i was becaming crazy...*
    For me the problem come from my project reference. I test to change my project reference by path reference and it work well. So if you got a project reference in your solution i purpose you to break it.

    Hope that will solve your problem too. It's not the best solution but it's a not too bad one...

    Good luck !


     

    Monday, May 21, 2007 4:40 PM
  • User1274337811 posted

    Hi vlemaire, thanks for your reply.

    After I posted my message before, and received no reply at all, I kind of assumed that the Web Deployment project people must have moved on to other things. This suggested to me that I shouldn't be using a Web Deployment project at all. So, I moved everything over to a Web Application project and it now works fine.

    It's a shame, though. Web Deployment projects would be a pretty reasonable idea if they worked!

     

    Tuesday, May 22, 2007 3:56 AM
  • User1938323788 posted

    I have the same problem. I'm trying to deploy a WCF service. Dealing with this is a huge waste of time for our company. We have 10 clients with different config file settings for each and because we can only get the service to compile in "Release" mode, we have to then edit the config file manually after we deploy. This is absolutely ridiculous for a supposedly "professional" tool. Typical M$ though.  

    Wednesday, May 23, 2007 8:07 PM
  • User1766825626 posted

    Take a look at the msnd's following page
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=205738&SiteID=1
    hope it will work for you.
    Kind Regards.
    Shahid Khan
    http://www.PerthIT.net

     

    Thursday, May 24, 2007 4:26 PM