locked
Excel abrubtly stops loading Add-in RRS feed

  • Question

  • Hi,

    We're developing an Add-In for Excel and this is the second time in 2 days that it stops loading.

    We created the Add-In using Yeoman's Office Generator

    I'm running it locally using the command `npm run dev-server` which runs a local webpack server serving on localhost.

    The server is working well and serves the taskpane as it should.

    Also, the manifest file which points to the localhost server works well on Office 365 on the Web.

    However, while testing out some changes to our login flow (using Auth0 and the MS DialogApi) the page broke completely, showing the following error message:

    'Sorry, we can't load the add-in. Please make sure you have network and/or internet connectivity. Click "Retry" once you're back online.'

    Trying to reload the add-in produced the exact same error message.

    A few more notes:

    1. Loading the manifest that points to the web-based (non-local) server still works.
    2. Loading the localhost-based manifest on the Web Excel still works.
    3. Reverting the entire git repo containing the entire project (including the manifest, etc.) to a state that is known to work well does not help.
    4. I currently can't use the Edge DevTools Preview for the add-in since the add-in does not even load and therefore is not recognized by the DevTools.

    I tried resolving it in multiple ways, to no avail, and this morning finally simply performed a complete Windows reset.

    The reset did fix the problem, but after a few hours of tinkering with the code the problem returned.

    I couldn't find any references to such a problem anywhere, and would greatly appreciate any help.


    Monday, June 1, 2020 12:12 PM