none
Eror: Verify kinect depth and color streams RRS feed

  • Question

  • Detects depth and color stream latency

    Result: Waiting for frames from kinect

    I searched all things on the web, but nothing happens. How to solve it?

    Saturday, March 21, 2015 1:53 AM

All replies

  • See the troubleshooting guide for things to look for: https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk

    What is the power profile set on the machine? Is the error you are getting from Kinect Configuration Verifier, if so have you tried another machine? Latency in frames is an issue with bandwidth from the USB3/PCIx bus to runtime.


    Carmine Sirignano - MSFT

    Monday, March 23, 2015 5:31 PM
  • Thank you for the reply. Can I increase the power setting on Bios setting? On windows, I set High performance mode. My power is 500w. Maybe I think the problems is due to my power, but I don't sure.

    I wonder that if I buy a product on http://www.startech.com/Cards-Adapters/USB-3.0/Cards/2-Port-PCI-Express-SuperSpeed-USB-3-Card-Adapter~PEXUSB3S2 , my problem is solved or not.


    • Edited by jakeoung Tuesday, March 24, 2015 3:05 PM
    Tuesday, March 24, 2015 3:03 PM
  • You would need to ask the manufacturer of the board on how power/energy saving settings can be disabled on your system. This is not a feature of Windows but of the CPU. Most i7 have a "turbo" type mode it can go into if you use the high performance energy profile in Windows.

    Carmine Sirignano - MSFT

    Tuesday, March 24, 2015 7:30 PM
  • I had a similar problem with a PC with Window 10 Pro N 64 bits, the Kinect V2 worked for a couple of months and then out of the blue it stopped working, I tried reinstalling the KinectV2 SDK v2.0_1409 several times and updating the USB 3.0 drivers, but nothing seemed to work. Then I tried to open the Color Basics-WPF sample from the Kinect Browser and it showed me that the PC was missing a MFPlat.dll, so I downloaded and installed the Windows_MediaFeaturePack from here www.microsoft.com/en-us/software-download/mediafeaturepack, restarted the computer and now the Kinect works again. I hope it helps.
    • Edited by Yoás Wednesday, July 25, 2018 5:31 PM
    Wednesday, July 25, 2018 5:30 PM
  • hi, this is Irshad,

    As I came to know with this issue and I have solved it, as this error occurs due to the power supply and the motherboard, so I tried to change the motherboard which has USB 3.0 built in, this problem will be resolved.

    Tuesday, April 2, 2019 7:19 AM