none
disable or stop Windows Performance Analyzer RRS feed

  • Question

  • My user's local folder is full of Windows Performance Analyzer Trace files.  New files are added hourly.  I do not know how I enabled this and cannot find a post or documentation to stop of disable creation of these files in users/username/appdata/local/temp folder.

    Thank you in advance for any advise.

    Tuesday, August 16, 2016 9:37 PM

All replies

  • I have the same issue.  Unfortunately, not replies to this.  :(
    Wednesday, March 1, 2017 5:21 PM
  • Bring up Computer Management, then go to System Tools->Performance->Data Collector Sets->Event Trace Sessions, also look in Startup Event Trace Sessions. There, you will find a list of the running trace sessions. You can double-click on a session to bring up the property box, and find the session that is writing to your directory. You can stop the session by right-clicking on it and selecting stop, or use an Admin command prompt and type "logman stop <session-name> -ets"

     -Brian


    Azius Developer Training www.azius.com Windows device driver, internals, security, & forensics training and consulting. Blog at www.azius.com/blog


    • Edited by Brian Catlin Wednesday, March 1, 2017 8:21 PM
    • Proposed as answer by Strategic IT Wednesday, February 6, 2019 11:40 AM
    Wednesday, March 1, 2017 8:21 PM
  • This doesn't help in my case.

    I only got rid of it as I deleted every registry entry which containes WPRAPP in name.

    Friday, March 2, 2018 10:44 AM
  • I my case, I noticed a "slight" reduction in free space on "C:".
    A visual file inspection tool showed that a 250GB Collector file had accumulated in just under 48 hours…

    Using Brian's procedure above, I navigated to the Event Trace Sessions, checking each one, until I found the culprit that was writing to the same directory where I found the grossly overgrown logfile.
    I chose to export a backup of the Template (from context menu) to re-create if necessary, then deleted it from existence.

    Then I deleted the overgrown file in question, and all was well with the world...

    Wednesday, February 6, 2019 11:50 AM
  • I had the similar situation creating huge logs sitting under windows\system32\*.etl so deleting won't help. you have to turn it off to stop creating etl logs.

    wpr -disablepagingexecutive off

    Thursday, November 14, 2019 3:01 PM