none
What does this mean and how do I fix RRS feed

  • Question

  • The failure is pasted in below. The applications mentioned in the diagnostics are all real and mine. Deployment of them has been attempted at a previous time and I have to my best ability removed any trace of their existence. The test application that I am attempting to run makes no reference to any of these mentioned applications and yet it seems that this blockage is occurring no matter what I am running. I am seeking help from anyone regarding:

    1.  Modifying my config.web file as suggested in the dump.

    2. Some explanation of the dump so that I can understand what I have done wrong in terms of friends etc.

    GHratefully,

    eps123


    eps123

    Thursday, July 7, 2016 2:14 PM

Answers

  • Hi eps123,

    According to the error message in your original post, except set owin:AutomaticAppStartup as false in Web.config, we also need "To specify the OWIN startup Assembly, Class, or Method, add the appSetting owin:AppStartup with the fully qualified startup class or configuration method name in your Web.config".

    And based on the first error message in your original post, it seems that there are several application has the same friendlyname. Please check the "[assembly: OwinStartupAttribute(typeof(WebApplication1.Startup))]" in all your application to confirm they are not in the same name.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by eps123 Friday, July 15, 2016 5:54 PM
    Friday, July 15, 2016 2:38 AM

All replies

  • Hi,

    can you give more details what you did? What assemblies are on the server? Did you configure any appSettings in your web.Config file?

    My understanding is, that you have multiple assemblies which all have a OwinStartup attribute. So the server does not know which one it should use.

    The OWIN Startup configuration can be found at http://www.asp.net/aspnet/overview/owin-and-katana/owin-startup-class-detection.

    I hope that helped a little bit.

    With kind regards,

    Konrad

    Sunday, July 10, 2016 9:44 AM
    Moderator
  • Thank you for your interest.  I obviously need an education on Owin.  I have tried to remove the applications that are mentioned in  the dump even without knowing what I am violating.  Hopefully, the link you have provided will shed some light on this.  When I have done this, I will most certainly get back tol you with some intelligent questions or ask you for a further reference.

    eps123

    Monday, July 11, 2016 1:44 AM
  • Hi eps123,

    you are always welcome. And there are no "dumb" or "intelligent" questions and there is no problem comming here with all these problems. We will try to help you where we can.

    If you need a starting point for OWIN, then maybe the following link is useful:
    http://www.asp.net/aspnet/overview/owin-and-katana

    With kind regards,

    Konrad


    Monday, July 11, 2016 5:14 AM
    Moderator
  • I have reviewed the information in the link you provided and the link is wonderful in shedding light on what is going on.  I am anxious to apply this knowledge so being somewhat lazy, I would prefer to disable startup processing to see if that solves my problem.  There is no direct instruction on disabling it so I took a shot at it.  The web.config file shown below is the only modification I have tried with my change indicated in the body.

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
      </configSections>
      <connectionStrings>
        <add name="DefaultConnection" providerName="System.Data.SqlClient" connectionString="Data Source=(LocalDb)\v11.0;Initial Catalog=aspnet-WebApplication17-20160613185458;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnet-WebApplication17-20160613185458.mdf"/>
      </connectionStrings>
      <system.web>
        <compilation strict="false" explicit="true" targetFramework="4.5" debug="true"/>
        <httpRuntime targetFramework="4.5"/>
        <pages>
          <namespaces>
            <add namespace="System.Web.Optimization"/>
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt"/>
          </controls>
        </pages>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login" timeout="2880" defaultUrl="~/"/>
        </authentication>
        <profile defaultProvider="DefaultProfileProvider">
          <providers>
            <add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/"/>
          </providers>
        </profile>
        <membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/"/>
          </providers>
        </membership>
        <roleManager defaultProvider="DefaultRoleProvider">
          <providers>
            <add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/"/>
          </providers>
        </roleManager>
        <!--
                If you are deploying to a cloud environment that has multiple web server instances,
                you should change session state mode from "InProc" to "Custom". In addition,
                change the connection string named "DefaultConnection" to connect to an instance
                of SQL Server (including SQL Azure and SQL  Compact) instead of to SQL Server Express.
          -->
        <sessionState mode="InProc" customProvider="DefaultSessionProvider">
          <providers>
            <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection"/>
          </providers>
        </sessionState>
      </system.web>
      <runtime>
    <!--
        The three lines below were insertyed in the attempt to disable owin startup
        -->
        
      <appSetting>
      <add key="owin:AutomaticAppStartup " value="false"    />
    </appSetting> 
    
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="DotNetOpenAuth.Core" publicKeyToken="2780ccd10d57b246"/>
            <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.1.0.0"/>
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="DotNetOpenAuth.AspNet" publicKeyToken="2780ccd10d57b246"/>
            <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.1.0.0"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
          <parameters>
            <parameter value="v11.0"/>
          </parameters>
        </defaultConnectionFactory>
      </entityFramework>
    </configuration>
    

    The resulting deployment was not successful so I am hoping that I have misplaced the statements and that I might still succeed.  The result is pasted in below and I will appreciate your oversight.


    eps123

    Monday, July 11, 2016 9:26 PM
  • Hi eps123,

    According to your Web.config, you add the appSetting node in the runtime node. In my opinion, the it should be appSettings and it should be under the configuration node.

    So please add the appSettings node to the configuration node, which is at the same level with the runtime node. Please refer to following Web.config snippet.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, July 14, 2016 2:43 AM
  • Thank you for the answer I was seeking.  I am showing the resulting modified web file where the appsetting lines were inserted after "system.web" and within the configuration node.  Following that, is the error diagmnostic I receive when I attempt to publish.  It seems to say that I am missing a section declaration before the appsettings.

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration> 
       
    
     <!--<section name="MyApp.Properties.Settings" type="System.Configuration.ClientSettingsSection,
              System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />-->
                
    
     
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 
       When no action is taken, I get a profusion of diagnostics regarding the starttup assemblies. This involves the correction of the assembly startup routine processor
       owin.  In the directions for handling the exception is the following statement:
       "To disable OWIN startup discovery, add the appSetting owin:AutomaticAppStartup with a value of "false" in your web.config."
       I am searching for the correct statements and the location in which to place them in my web.config file.
    
       The following 3 lines I am guessing, need to be inserted somewhere in this file
       
       <appSetting>
      <add key="owin:AutomaticAppStartup " value="false"    />
    </appSetting> 
    -->   
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
      </configSections>
     <connectionStrings>
        <add name="DefaultConnection" providerName="System.Data.SqlClient" connectionString="Data Source=(LocalDb)\v11.0;Initial Catalog=aspnet-WebApplication17-20160613185458;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnet-WebApplication17-20160613185458.mdf"/>
      </connectionStrings>
      <system.web>
        <compilation strict="false" explicit="true" targetFramework="4.5" debug="true"/>
        <httpRuntime targetFramework="4.5"/>
        <pages>
          <namespaces>
            <add namespace="System.Web.Optimization"/>
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt"/>
          </controls>
        </pages>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login" timeout="2880" defaultUrl="~/"/>
        </authentication>
        <profile defaultProvider="DefaultProfileProvider">
          <providers>
            <add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/"/>
          </providers>
        </profile>
        <membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/"/>
          </providers>
        </membership>
        <roleManager defaultProvider="DefaultRoleProvider">
          <providers>
            <add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/"/>
          </providers>
        </roleManager>
        <!--
                If you are deploying to a cloud environment that has multiple web server instances,
                you should change session state mode from "InProc" to "Custom". In addition,
                change the connection string named "DefaultConnection" to connect to an instance
                of SQL Server (including SQL Azure and SQL  Compact) instead of to SQL Server Express.
          -->
        <sessionState mode="InProc" customProvider="DefaultSessionProvider">
          <providers>
            <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection"/>
          </providers>
        </sessionState>
      </system.web>
        <appSetting>
         <add key="owin:AutomaticAppStartup " value="false"    />
        </appSetting> 
    
    <runtime>
    <!--
        The three lines below were insertyed in the attempt to disable owin startup
          <appSetting>
      <add key="owin:AutomaticAppStartup " value="false"    />
    </appSetting> 
      -->
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="DotNetOpenAuth.Core" publicKeyToken="2780ccd10d57b246"/>
            <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.1.0.0"/>
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="DotNetOpenAuth.AspNet" publicKeyToken="2780ccd10d57b246"/>
            <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.1.0.0"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
          <parameters>
            <parameter value="v11.0"/>
          </parameters>
        </defaultConnectionFactory>
      </entityFramework>
        </configuration>
    <!--
      <configSections>
    
     <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, 
                   Culture=neutral, PublicKeyToken=b77a5c561934e089">
    
     <section name="MyApp.Properties.Settings" type="System.Configuration.ClientSettingsSection,
              System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    
     </sectionGroup>
    
     </configSections>
     -->



    eps123


    • Edited by eps123 Thursday, July 14, 2016 2:42 PM insert
    Thursday, July 14, 2016 2:12 PM
  • Hi eps123,

    According to the error message in your original post, except set owin:AutomaticAppStartup as false in Web.config, we also need "To specify the OWIN startup Assembly, Class, or Method, add the appSetting owin:AppStartup with the fully qualified startup class or configuration method name in your Web.config".

    And based on the first error message in your original post, it seems that there are several application has the same friendlyname. Please check the "[assembly: OwinStartupAttribute(typeof(WebApplication1.Startup))]" in all your application to confirm they are not in the same name.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by eps123 Friday, July 15, 2016 5:54 PM
    Friday, July 15, 2016 2:38 AM
  • Thank you for the response.  The error I first got seemed to indicate that I could eliminate all discussion of owin startup if I could just disable it.  I first learned of this roadblock to completing a project I have worked on for a year, when I went to deploy a little test routine.  I see from your answer that it requires a lot of knowledge of the  towin in order to bypass it.  I do not know what I did in my development efforts that caused this monster to appear.  Not wanting to appear lazy, I have gone to a link that had been provided me to study OLWIN and the KATANA project.

    It involves far more than I had hoped would be required to deploy my relatively simple three project solution.  I have tried a very detailed walk-through on the link and in failing, I concluded that it would consume much more time to finish than I am willing to give.  So, instead, let me ask you if there is an alternative to OWIN in seeking a method to deploy.  I have run applications on my site in the past even though they were not formally deployed and I did not encounter the stoppages I am seeing recently.  So, my question is what is my alternative to developing that does not lead to this statrtup discovery problem? Where shall I post this question if you cannot answer me?

    Thank you.


    eps123

    Friday, July 15, 2016 6:21 PM
  • Hi eps123,

    Thanks for your response.

    Since this forum is discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor.

    If you occurs this issue when developing this application, please post your problem to ASP.NET forum. And if your project can build and run successful in Visual Studio, just has this issue after deploying to server, please post your problem to Web Deployment forum to get better help.

    Thanks for your understanding.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 18, 2016 12:49 AM