locked
E-mail problem RRS feed

  • Question

  • User380413204 posted

    Hi,

    I would like to use E-mail with this kit.

    I use the Club Starter Kit on a normal PC using Windows XP Pro

    When I try the "forgot password" functionality I get the following error:

    A from e-mail address must be specified in the From property or the system.net/mailSettings/smtp config section.

    Is it possible to use email with XP Pro and IIS, or do I need a different OS, like a Server editon or something?

    And if it is, can someone please point me into the right direction to make it work?

    Thanks for any help,

    Lex

    Saturday, February 18, 2006 7:09 AM

All replies

  • User2069888697 posted
    You need to goto asp.net configuration(the same place you create user roles) and goto application settings and configure smtp e-mail settings.
    Saturday, February 18, 2006 5:02 PM
  • User380413204 posted

    Hi,

    Thanks,

    Ok, did that.

    But now I get this:

    Mailbox unavailable. The server response was: 5.7.1 Unable to relay for <the email adress entered in From in Application Settings>

    I probably need to adjust some more settings

    But which?

    Thanks in advance  

    Lex

    Saturday, February 18, 2006 5:53 PM
  • User380413204 posted

    Sorry about this but I solved the first part (in IIS relay-settings were not made) I corrected that I think, because now I get the text: Your password has been sent to you

    So of course this filled me with joy,

    But........you guessed it.  No mail arrives at the given address.

    So I have to adjust my previous question to:

    What's the problem this time?

    Thanks

    Lex

     

    Saturday, February 18, 2006 6:15 PM
  • User380413204 posted

    Hi,

    And again I feel I get a little bit closer:

    The messages are stored in a folder called:

    C:\Inetpub\mailroot\Queue

    When I tried to read them the first time the Microsoft Wizard for setting up Outlook Express.appeared.

    I followed that for POP3 and SMTP-settings (But I don't really need that for .net mail do I?)

    Anyway the messages stay in that queueFolder.

    What am i missing here?

    Thanks,

    Lex

     

    Saturday, February 18, 2006 6:32 PM
  • User2069888697 posted

    I have 3 club starter kits up and running. 1 on crystal tech and 2 on web4life. All work fine with smtp configured.

    1. If using Visual Studio after making the changes in asp.net configuration you should get a prompt that the web.config has been changed outside the source editor, except these changes and copy the new web.config to your hosting site.

    this is a sample of what should be added

    <mailSettings>

    <smtp from=You@YourDomain.com>

    <network host="mail.YouDomain.com" password="1234" userName="You@YourDomain.com" />

    </smtp>

    </mailSettings>

    2. check to make sure that server name is your smtp.yoursite.com or mail.yoursite.com, whichever your email hoster requires, next make sure your server port info is what your hoster requires(25 is normal but some require different settings), then verify whether your hoster requires smtp authentication( ie username and password).

    I'm sorry if this doesn't help but it's all I have.  Good Luck

    Saturday, February 18, 2006 10:47 PM
  • User380413204 posted

    Hi MainOne,

    You just made me a happy man. The tone of your last post seems almost apologetic (if that's english), no reason for that......It works!

    You put me on the right track with your info. The webconfig was indeed the problem.

    Thank you for the information!

    Regards,

    Lex

     

     

    Sunday, February 19, 2006 2:53 AM
  • User-25459473 posted

    My outgoing mail server for 1and1.com requires outgoing SMTP Authentication AND uses a different port. How can I configure these?

    -Josh

    www.DomainGuarder.com - Domain Watching Service 

    Tuesday, December 14, 2010 7:12 AM
  • User-25459473 posted

    Here are the current settings I have that the server does not accept for authenticated outgoing mail

     

      <system.net>
        <mailSettings>
          <smtp from="info@domainguarder.com">
            <network defaultCredentials="true" host="smtp.1and1.com" password="" userName="info@domainguarder.com" />
          </smtp>
        </mailSettings>
      </system.net>


     

    Tuesday, December 14, 2010 2:20 PM