none
Points for Gallery activity not recovered after replay. RRS feed

Answers

All replies

  • It has been a few days since the replay of activities. Any information would be appreciated.

    Thanks

    Dave


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    Saturday, January 19, 2013 9:43 AM
  • Still waiting...

    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    Wednesday, January 23, 2013 5:47 PM
  • Still waiting but there are many other problems with what should be higher priority...

    In getting here I had to wait for the very slow reponse of the profle and forum info (on right). Been like that for a few days. And this thread was not visible in the forum as it resided in the reported paging void between the first and second pages. Then the lack of avatars and names in the postings. Posting and then editing a post does at least make your name appear with your post like this!

    I'll just continue to be patient.


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.



    • Edited by Xpert360 Friday, January 25, 2013 7:38 AM
    Friday, January 25, 2013 7:36 AM
  • Can't repro the problem with the info loading on the right.

    Points for Gallery... this is a topic for the Profile forum. Moving the thread to that forum.


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Monday, January 28, 2013 10:52 PM
    Owner
  • Thanks Ed.

    The info loading slowness has gone away. It was just for 2 or 3 days. You had to wait for it to load before 'reply' was enabled which sometimes was more than a minute.

    Nice to see the recent problems starting to be resolved and some normality returning to the forums :)


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    • Proposed as answer by Livio von Büren Tuesday, January 29, 2013 9:10 AM
    • Unproposed as answer by Xpert360 Monday, February 4, 2013 2:53 AM
    Tuesday, January 29, 2013 9:09 AM
  • Any response at all on the missing points?

    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    Friday, February 1, 2013 3:27 PM
  • It has now been nearly one month since the problem happened and there has still been no response. With all the details provided I would not expect it to take too long to take a look and provide some form of early assessment of the situation?

    I have another sample just 7 downloads short of 1000 and having never seen the points for 1000 downloads I am filled with hesitant excitement...


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.


    • Edited by Xpert360 Saturday, February 9, 2013 8:21 PM
    Saturday, February 9, 2013 8:19 PM
  • I think in some cases if the points were missed, then they could never be returned unless all your activity will be re-calculated (which is unlikely event). Say, due to forum's bugs I lost about 15K points so far (and keep losing every day), but I didn't get any response from forum's admins.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    Sunday, February 10, 2013 8:07 PM
    Moderator
  • So let's prove it. You have 975 points for the Gallery. How many points should you have, and what's the proof (links and reasons).

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Sunday, February 17, 2013 1:18 PM
    Owner
  • Profile: downloads: 2397

    "The samples that I mentioned are:

    http://code.msdn.microsoft.com/vstudio/Control-Colors-of-DataGrid-fa23c265

    1408 download

    http://code.msdn.microsoft.com/vstudio/Clear-user-sort-settings-7703e340

    1036 downloads

    Total should be ~ 2444

    As I am not some forum or gallery superstar it makes the sums simpler :)

    Before the ealy January 'outage' the numbers matched exactly. So during the outage some ~47 downloads did not get accounted for in the profile and it just so happened that 'Control-Colors-of-DataGrid-fa23c265' surpassed 1000 downloads in that time and the 500 points never got added to my profile. If it was not for that I would not really have noticed.

    Since then 'Clear-user-sort-settings-7703e340' surpassed 1000 downloads and that worked fine.

    I thought at the time that while the forum activity was being replayed that perhaps the gallery activity could be too. It is no big deal, the points, just thought it would help.


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    Sunday, February 17, 2013 4:28 PM
  • Right. I'm no Gallery superstar either. =^)

     

    So more details here...

    • You have 975 points for Gallery contributions
    • 1408 downloads should be 500 points
    • 1036 downloads should be another 500 points
    • It says you have 5 Gallery contributions in your profile, but I only see 2 on MSDN. Are the other 3 on TechNet?
    • So you should at least have 1,000 points, based on the 1,000 download milestones (500 points x 2)
    • Based on this guide (http://msdn.microsoft.com/en-US/ff395928.aspx#How_do_I_earn_points_), you should also have +20, +50, and +100 for each of these two items (in addition to the +500 I mentioned). So really each item should have +670.
    • That puts you at 1,340 points (670 x 2 items).
    • Now it also says in your profile that you had 14 4+ star ratings. Okay, I'm not sure what the split is, but it looks like the 4 ratings on MSDN are all 5 star ratings (or else the stars wouldn't be full like that). I'm not going to look you up on TechNet Gallery. You've got to send me the link and do more math if you care. =^)
    • So if you have 4 ratings that are 5 stars, at 10+ points each, that's another 40 points. Then if we just assume that the remaining 10 4+ star ratings you got (on TechNet Gallery?) are all four stars, that's still another 50 points (5+ points times 10 ratings).
    • That leaves you with a grand total of 1,340 points (from milestones of those two items), plus another 90-140 points (from 4+ star ratings)... and your grand total is 1,430 points to 1,480 points.

     

    So, before I submit this as a bug request, do you want to do some math and see what stats you have over on TechNet Galleries?

    I would need to know how many items got how many milestones and should have how many points. And of those 10 remaining 4+ ratings, how many were 4 stars versus 5 stars.

    And you can technically lose points for 1 and 2 star ratings (http://msdn.microsoft.com/en-US/ff395928.aspx#How_do_I_earn_points_), but on MSDN Gallery I didn't see any evidence of that, so I haven't factored it in.

     

    You asked: Why is this taking one+ months?

    Two reasons:

    1. It's really complicated on the back end. Someone needs to prove the case that you're actually losing the points. Someone needs to "do the math".

    2. I did most of the math, since at least you sent me two links and got the math started.

     

    So... could you do the rest of the math, please? We need the equivalent done on any other Gallery items you have (likely TechNet, but it might be VS or some other pocket). I could submit you with these 1,430 points, but if the fix is for them to manually add your points together, you might miss out on other points that you're not listing here.

    Thanks for responding quickly!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!



    Friday, February 22, 2013 10:30 PM
    Owner
  • On MSDN Samples Gallery I see 1083 downloads and 1-5 star rating for:

    "Manipulate sort and column settings programmatically"

    Your activities show you got credit for 1000 downloads 12 days ago (it never mentions the points). I also see 1475 downloads and 3-5 star ratings for:

    "Control colors of DataGrid rows and other UI elements in LightSwitch"

    For the first article, you should have 20 pts for 20 downloads, plus 50 pts for 50, plus 100 pts for 100, plus 500pts for 1000 downloads, plus 30 points for the 3-5 star ratings. This totals 700 points. I know it works this way because I saw it happen to a few of my gallery contributions. For the second article you should have 20 + 50 + 100 + 500 + 10 = 680 points. The grand total should be 1380. Your profile shows 975 points, so the difference is 405. I can't see how that happened. But of course I'm going by the rules in the TechNet Gallery. And, in your profile it says 5 articles and 14 4+ ratings, so I don't know where those extra articles are. I don't know how to find contributions by author, so I cannot find any of yours in the TechNet Gallery.


    Richard Mueller - MVP Directory Services


    Saturday, February 23, 2013 12:04 AM
    Moderator
  • I must admit I have not paid much attention to my points. I have noticed most of the gallery activity in my profile, but except for the 500 point milestones, I can't say for sure that I was credited with the correct points.

    I did the same analysis on my 9 TechNet Gallery contributions as I did above. I have to estimate the star ratings, but I can see the download numbers. My conservative estimate is that I should have 2805 gallery points, but the circular chart in my profile shows 2316. Maybe there is something going on.


    Richard Mueller - MVP Directory Services

    Saturday, February 23, 2013 12:58 AM
    Moderator
  • Hi Ed & Richard,

    Many thanks for taking a look, you are pretty much spot on.

    The other three contributions are in the Visual Studio Gallery:

    http://visualstudiogallery.msdn.microsoft.com/c3774d50-a695-4a89-a8d0-6f0b55711ad9

    has 6 x 5* and 772 clicks

    http://visualstudiogallery.msdn.microsoft.com/ca4cd6f3-84af-4620-a289-1f55469839ef

    has 3 x 5*, 1 x 4* and 599 clicks

    http://visualstudiogallery.msdn.microsoft.com/0787c259-f99d-4a0e-87ff-a748e5d8e609

    has 406 clicks

    Their downloads are off-site because the gallery does not supported signed distributables other than Verisign (I believe). So uploading signed code is not an option for us as we have GlobalSign certificates. Uploads always fail. The clicks do not count towads points.

    So the total points should be 1475. The missing points tally is 500 for the 1000 download milestone reached in the midst of the early January problems.

    The total downloads and other gallery reviews etc at that time just got lost and not replayed. The problematic weekend I took timeout to try out and review several gallery contributions which is my bad timing.

    I was more interested in this being a pointer to other people's point losses. If there is a chance to 'search' for star ratings and download milestones for others during the outage then it would be great. The forum activity was replayed well but this piece got missed.

    Many thanks! :)

    Dave


    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.



    • Edited by Xpert360 Saturday, February 23, 2013 11:53 AM
    Saturday, February 23, 2013 11:51 AM
  • Not sure what they'll do. But I can send them bugs with proof. Between your numbers and Richard's, I think it's a good case that this problem extends to lots of folks.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Sunday, February 24, 2013 2:59 AM
    Owner
  • Related note from Craig Lussier: 

     

    I had a Gallery contribution reach 20 downloads yesterday (February 22nd, 2013) sometime between 5-7pm Atlantic time. The contribution link is http://gallery.technet.microsoft.com/Identify-the-IIS-App-Pools-322de3fb. My activity feed was not updated and I did not receive 20 points. 

     

    From this thread: http://social.msdn.microsoft.com/Forums/en-US/Profile/thread/fc5432fd-6f9e-41a6-9946-c9e4c0c3b5bf


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!


    Sunday, February 24, 2013 3:00 AM
    Owner
  • I submitted this as a bug request.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Tuesday, March 5, 2013 6:10 PM
    Owner
  • Many thanks Ed!

    Dave Baker | Xpert360 blog | twitter : @xpert360 Opinions are my own. Please mark as answer if this helps solve your problem.

    Tuesday, March 5, 2013 6:32 PM
  • UPDATE: They logged Bug #1157278 on this.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Friday, March 22, 2013 1:02 AM
    Owner
  • UPDATE: They logged Bug #1157278 on this.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    hope this is fixed soon.

    i've lost 200 points or more in Gallery points (150 recently), also my 4+ Star Ratings are incorrect + i've not received many achievements...

    i would've thought on a programming forum, run by a major software company, you might be able to find a decent programmer to fix this:D


    thanks for any help

    Thursday, April 4, 2013 7:07 PM
  • I am also facing same problem. After 50 and now 100 downloads, I cannot see anymore updates in my point for this gallery contribution. 

    Thanks,
    Sachin
    My Samples | Personal Website

    Friday, April 12, 2013 1:44 PM
  • I am also facing same problem. After 50 and now 100 downloads, I cannot see anymore updates in my point for this gallery contribution. 

    Thanks,
    Sachin
    My Samples | Personal Website


    I've lost more than 800 points at the last time I checked...

    thanks for any help

    Friday, April 12, 2013 4:14 PM
  • Not sure if anything will be done after all this time :)

    Looking through this thread I like the 'Vote as helpful' seemingly randomly translated to Chinese. Perhaps that is an artefact of the earlier localization issues a few months back...


    Dave Baker | Xpert360 blog | twitter : @xpert360 | Xpert360 website Opinions are my own. For better forums, please mark as helpful/answer, if it helps/solves your problem.

    Wednesday, May 1, 2013 3:10 PM
  • Over time I've noticed my profile gallery statistics increasing. I think they are nearly caught up now (they will always be a little behind if you have downloads daily). As far as points, I think I'm up-to-date now.


    Richard Mueller - MVP Directory Services

    Wednesday, May 1, 2013 5:33 PM
    Moderator
  • Yeah is seems to be some kind of sync issue going on. Mine also increased recently and other interesting thing I observed that I have only two gallery contribution but I when go to experience tab in my profile it shows three (one bonus :) ) 

    Thanks,
    Sachin
    My Samples | Personal Website

    Wednesday, May 1, 2013 5:49 PM
  • The problem you are experiencing is different, but nice to hear it is being resolved.

    The points that went missing in Jan 2013 are missing and I am not hopeful of a resolution.


    Dave Baker | Xpert360 blog | twitter : @xpert360 | Xpert360 website Opinions are my own. For better forums, please mark as helpful/answer, if it helps/solves your problem.

    Thursday, May 2, 2013 7:27 AM
  • I also am having problems with a contribution. Not sure if this is the correct forum for this.

    My http://gallery.technet.microsoft.com/Skype-63-Silent-Installer-74a99dcd reached 50 downloads over a month ago (currently at 72) but I never received the points for the 50 downloads.

    Thanks


    Regards, ~P MCSE, MCITP, MCTS, MCP, CCNA

    Friday, July 19, 2013 9:09 AM
  • Hi,

    Ed did his best to highlight the problems and we verified the discrepancies are real.

    It has been more than 6 months now so I am not really expecting anything to be done as no-one even bothered to respond?

    Cheers

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Friday, July 19, 2013 12:07 PM
  • If you will not get your points in the next month, I suggest to email to fissues at microsoft dot com and let them know.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Friday, July 19, 2013 2:20 PM
    Moderator
  • I still have this issue. I lost 100 points for 101 downloads. Can some one helpe me ?

    http://gallery.technet.microsoft.com/scriptcenter/Windows-System-Inventory-616e2749

    101 downloads but the points stopped on July-27-2013.

    Sunday, August 4, 2013 9:14 AM