locked
Unable to start UI Test on iOS simulator RRS feed

  • Question

  • User323122 posted

    Hi I have a Xamarin UI test project with tests apps on iOS and Android simulators. Since today I had to update xCode and since the update I can no longer start the iOS app on the simulator from my UI Test project.

    I just get the error TestFixtureSetUp failed in "myTestProject”.

    The app is started as follows: return ConfigureApp .iOS .InstalledApp(installedApp) .DeviceIdentifier(123456-123456) .PreferIdeSettings() .EnableLocalScreenshots() .WaitTimes(new WaitTimes()) .Debug() .StartApp(ClearData);

    And this command returns the following error/exception: Unable to determine simulator version for 123456-123456 BUT the simulator ID is good. I can see it listed when I list my iOS simulators. And it says that the simulator is Booted.

    I use the following nuget packages 1. NUnit 2.6.4 2. NUnit.Runners 2.6.4 3. NUnitTestAdapter 2.1.1 4. Specflow 1.9.0 5. Xamarin.UITest 2.2.5

    This all worked fine (yesterday) before the update. Any ideas?

    (Sorry... I cant seem to format the code other than making it bold)

    Tuesday, March 26, 2019 3:13 PM

All replies

  • User378120 posted

    I am having the same issue with the new update from Xcode No idea how to fix it I would like to keep tabs on this post for updates

    Tuesday, March 26, 2019 7:58 PM
  • User378120 posted

    I worked with App Center Dev ops on this issue and here is the conclusion they came too:

    I've got a workaround for the issue, though it's a little bit painful: Workaround based on: https://www.client9.com/uninstall-xcode-on-macos-sierra/

    Deleted all copies of Xcode and clear them from trash

    Deleted /Users/[USERNAME]/Library/Developer/Xcode/

    Deleted /Users/[USERNAME]/Library/Caches/com.apple.dt.Xcode & two other cache folders com.apple.dt.Xcode.ITunesSoftwareService & com.apple.dt.Xcode.sourcecontrol.Git

    Deleted /Library/Developer/CommandLineTools & CoreSimulator & PrivateFrameworks Reinstall Xcode 10.1

    VS for Mac only see "Generic Simulator" (probably because we deleted them in the above steps) Close VS for Mac & launch Xcode to auto install default simulators

    Start VS for Mac

    Functionality is restored with Xcode 10.1

    There may be slight differences because of how Xcode was installed on the local machine. I suspect as long as the various cached and other Xcode files are present and then deleted, it should clean it out. Please let us know if this workaround is ineffective for you. We expect that a Xamarin.UITest update soon will resolve the underlying problem so Xcode 10.2 can work, our apologies for the inconvenience.

    Monday, April 1, 2019 2:06 PM
  • User384166 posted

    Moshex,

    Thank you. Will try this solution. 3 days in row I'm trying to solve it

    Monday, April 1, 2019 3:29 PM
  • User384166 posted

    This solution does not work to me. before update Mac OS to 10.14.4 Mojave and Xcode to 10.2 everything worked fine.

    Now after deleting Xcode 10.2 and reinstalling Xcode 10.1 simulators became accessible only for application project. for ui test VS still doesn't see simulators

    Monday, April 1, 2019 7:37 PM
  • User378120 posted

    Did you downgrade your os as well?

    Tuesday, April 2, 2019 3:06 AM
  • User384166 posted

    @Moshex said: Did you downgrade your os as well?

    Only downgrade of OS to 10.14.3 (previous) and Xcode to 10.1 helped.

    Friday, April 5, 2019 8:37 AM
  • User378120 posted

    @cheer2cheer said: @Moshex said: Did you downgrade your os as well?

    Only downgrade of OS to 10.14.3 (previous) and Xcode to 10.1 helped.

    I see, glad you got the issue resolved.

    Friday, April 5, 2019 11:57 AM