none
Unable to install .Net 3.5 SP1 under VIsta x64 SP1 RRS feed

  • Question

  • I have a clean (no other applicatons ever installed) copy of Vista x64 SP1 installed (Hyper-V).

    Whenever I try to install the .Net Framework 3.5 SP1 it fails returning "Incorrect Function"; when I check thelog file it has "Process exited with code 1".

    This occurs whether I try to install with a local copy of the Framework or by tryign to download.

    I have already tried the following with no success (all as administartor):

     1.  Aaron Stebner's .Net Framework Cleanup Tool;
     2.  reg delete HKLM\Components /v StoreDirety /f (couldn't find key/value);
     3.  Winmgmt /verifyrepository (returns ok/no inconsistencies found);

    As an FYI -- the same copy of the framework installed fine on 32-bit Vista and on 32-bit XP.

    Any help/guidance/advice would be most appreciated!
    Wednesday, February 4, 2009 12:28 AM

Answers

  •  [02/03/09,16:38:40] BWaitForMSI(): Verifying we're the only installation currently in progress.

    Please make ensure that you're running one setup at one time.

    [02/03/09,16:38:48] Microsoft .NET Framework 2.0SP1 (x64) (CBS): ***ERRORLOG EVENT*** : Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code 1

    Vista SP1 has included .NET 2.0 sp1, please make sure the .NET Framework feature is checked on Vista. (via Control Panel->Programs and Features->Turn Windows Features On or Off > Microsoft .Net Framework 3.0)
    In case the .NET Framework installation is in a bad condition, you need to repair it: http://blogs.msdn.com/astebner/archive/2008/07/03/8685850.aspx

    And in the log I also see .NET 2.0 sp2 update also fails.
    You can try to extract the .NET Framework 3.5 sp1 package(use /x command argument or use some compression tool such as winrar), find the \DotNetFX35SP1\dotnetmsp\x64\NetFX2.0-KB948609-v6001-x64.msu and try to manually install this patch.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6

    • Edited by Figo Fei Friday, February 6, 2009 4:32 AM add repair steps
    • Marked as answer by Figo Fei Monday, February 9, 2009 3:06 AM
    Friday, February 6, 2009 4:10 AM

All replies

  • Can you please use the collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx?
    Please then upload vslog.cab using upload server and paste the link here.

    thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Thursday, February 5, 2009 6:00 AM
  • I've run the collect tool and have the vslog.cab file; its located at http://cid-6041905c3f12bdf4.skydrive.live.com/browse.aspx/logs
    Friday, February 6, 2009 12:36 AM
  •  [02/03/09,16:38:40] BWaitForMSI(): Verifying we're the only installation currently in progress.

    Please make ensure that you're running one setup at one time.

    [02/03/09,16:38:48] Microsoft .NET Framework 2.0SP1 (x64) (CBS): ***ERRORLOG EVENT*** : Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code 1

    Vista SP1 has included .NET 2.0 sp1, please make sure the .NET Framework feature is checked on Vista. (via Control Panel->Programs and Features->Turn Windows Features On or Off > Microsoft .Net Framework 3.0)
    In case the .NET Framework installation is in a bad condition, you need to repair it: http://blogs.msdn.com/astebner/archive/2008/07/03/8685850.aspx

    And in the log I also see .NET 2.0 sp2 update also fails.
    You can try to extract the .NET Framework 3.5 sp1 package(use /x command argument or use some compression tool such as winrar), find the \DotNetFX35SP1\dotnetmsp\x64\NetFX2.0-KB948609-v6001-x64.msu and try to manually install this patch.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6

    • Edited by Figo Fei Friday, February 6, 2009 4:32 AM add repair steps
    • Marked as answer by Figo Fei Monday, February 9, 2009 3:06 AM
    Friday, February 6, 2009 4:10 AM