Properties Window RRS feed

  • Question

  • Is there a reason why, when you are in source mode, and you click on a control the Properties Window is not populated?  I am almost positive that pre SP1 this worked.



    Wednesday, January 31, 2007 7:20 PM

All replies

  • Hi SLTDon,

    Yes, I think we have to expect a Service Pack install to reset some settings, and this is one of them. BTW, I think these instructions should also work for those who haven't activated the Properties Window in Source View, prior to or after the Service Pack install, but may wish to do so.

    To get the Properties Window Grid in Source View  functional in VS2005:

    1. Go to:Tools > Options > Text Editor > HTML > Miscellaneous
    2. Check the "Enable property grid in source view" checkbox.
    3. Close the Tools menu.
    4. Exit and then re-open Visual Studio 2005.
    5. Open a project work item in Source View.
    6. Make sure the Properties Window is showing in the IDE
    7. Click on any empty space in the Source View window.
    8. The Properties Window should then populate with the grid and data as it did before the Service Pack install.

    From what I could see, this checkbox is only present in the HTML Miscellaneous section of the Text Editor topic. It doesn't appear in any of the other language groups options, although I do stand to be corrected on that. This should get the Property Window grid popluated and working in most language groups, not only HTML.

    Please let us know if this solves the problem?


    Friday, February 2, 2007 10:16 AM
  • Very helpful Thank you !!


    But for the <body> tag  properties,    why don't   the   "topmargin"  ,  "bottommargin",  "leftmargin"  properties show up??

    Sunday, July 15, 2007 2:29 PM
  • Hi,


    I don't know the actual reason but I suspect it's because cascading style sheets are recommended to control margins.


    For example:



    body {

      margin: 0;

      margin-left: 3px;



    Link to the stylesheet in your XHTML document:  

    Code Snippet


      <link rel="stylesheet" type="text/css" href="Styles.css" />




    - Dave

    Sunday, July 15, 2007 7:12 PM