locked
No Debugger - - JavaScript runtime error: 'WebForm_InitCallback RRS feed

  • Question

  • User-26023612 posted

    Hi

    hi i try to debug a website on VS2013, i got the following error:  "JavaScript runtime error: 'WebForm_InitCallback'". And everything on the page that works by callback, just don't work.
    But when i just go to localhost on the browser, everything works.

    this is a project that i as assigned for. I don't have much knowledge about what is really going on. 
    but its a pain, doing "debug" by save file, open browser. Without getting the normal feedback and power of a debugger.

    Edit -------

    when i run the debugger with the IE
    first i got this error : 

    Exception was thrown at line 37, column 13509 in http://localhost:54132/bb97e2e8ab9f4ba1a22626e314673b4c/browserLink
    
    0x800a03f6 - JavaScript runtime error: Invalid character

    i can see the login page. I do the login. And when i'm waiting for the homepage i got:

    Unhandled exception at line 2621, column 1 in http://localhost:49196/
    
    0x800a1391 - JavaScript runtime error: 'WebForm_InitCallback' is undefined
    
    If there is a handler for this exception, the program may be safely continued.

    the file with error, is a dynamic file.

    <script type="text/javascript">
    //<![CDATA[
    
    WebForm_InitCallback();//]]>
    </script>

    Wednesday, October 26, 2016 4:32 PM

All replies

  • User-691209617 posted

    Hi,

    Which IE version you used at this moment. ?

    Lets try IE9 and the error at least only comes up once from the start when doing debugging. 

    Also I prefer to do debugging in Chrome, debugging is very much easier on Chrome.

    Hope down the road you can figure out what it doesn't like about it.

    Hope it Helps.

    Wednesday, October 26, 2016 6:03 PM
  • User-691209617 posted

    It is hard to give any solid solution with out any code. But , I came across few similar issue in the web I am sharing with you. Perhaps you might find something similar to yours.

    Wednesday, October 26, 2016 6:04 PM
  • User-2057865890 posted

    Hi Brochadinho,

    JavaScript runtime error: 'WebForm_InitCallback' is undefined

    It could be system data or .net framework issue, try updating system data and .net framework.

    reference: http://stackoverflow.com/questions/666172/webform-initcallback-is-not-defined 

    Best Regards,

    Chris

    Thursday, October 27, 2016 7:27 AM
  • User-26023612 posted

    Which IE version you used at this moment. ?

    Lets try IE9 and the error at least only comes up once from the start when doing debugging. 

    Also I prefer to do debugging in Chrome, debugging is very much easier on Chrome.

    i'm with the IE11, but the problem also affect other browsers. I have tried firefox, chrome and opera. all the same.

    but i will try change to another version. And i will try do as Chris suggested.

    Thursday, October 27, 2016 8:45 AM
  • User-26023612 posted

    Chris Zhao

    It could be system data or .net framework issue, try updating system data and .net framework.

    i just install the update for .net framework 4.6.2 and the problem persist. Should i remove the prior versions or just install the update for 4.5 since the project is targeting version 4.5I also tried the system time, with no luck

    The weird thing for me is. If i simple navigate to localHost, i can use he page with no problem, and this error don't appear.

    Do you have any other suggestion?


    thanks for you time and help.

    Thursday, October 27, 2016 9:17 AM
  • User-2057865890 posted

    Hi Brochadinho,

    Have you tried resting system date time? 

    Best Regards,

    Chris

    Wednesday, November 2, 2016 7:10 AM