none
.NET Runtime version 2.0.50727.5446 - Fatal Execution Engine Error RRS feed

  • Question

  • My operating system is Windows 7, 64-bit with Service Pack 1. I've only encountered this problem with two applications so far, Web Platform Installer 3.0 and SQL Server Express 2008 R2.

    In the case of WebPI 3.0, the install goes perfectly fine, but then any time I wish to start the application, it will crash immediately, bringing up a message saying that it stopped working and needs to close. The event viewer logs these two issues:

    .NET Runtime version 2.0.50727.5446 - Fatal Execution Engine Error (582BEA52) (80131506)

    Faulting application name: WebPlatformInstaller.exe, version: 7.1.1070.1, time stamp: 0x4d96afbe
    Faulting module name: mscorwks.dll, version: 2.0.50727.5446, time stamp: 0x4d8cdc73
    Exception code: 0xc0000005
    Fault offset: 0x000ca0c5
    Faulting process id: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report Id: %13

     

    For SQL Server, I cannot complete the installation because eventually I'll run into a problem with the CAS policy manager. The crash looks similar enough in the event viewer:

    .NET Runtime version 2.0.50727.5446 - Fatal Execution Engine Error (582BEA52) (80131506)

    Faulting application name: caspol.exe, version: 2.0.50727.5420, time stamp: 0x4ca2b913
    Faulting module name: mscorwks.dll, version: 2.0.50727.5446, time stamp: 0x4d8cdc73
    Exception code: 0xc0000005
    Fault offset: 0x000ca0c5
    Faulting process id: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report Id: %13

     

    I've gone through a lot of attempts at solving this, as seen here:
    http://forums.iis.net/t/1179666.aspx

    I've attempted to try this solution to repair my .NET installation:
    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    However, when I tried 'sfc /scannow', the scan always returns two files are still corrupted. I tried copying the relevant files from my installation DVD, but it didn't stop any of the errors. These persist even if I do the sfc after a clean boot or on Safe Mode. The relevant lines from the sfc scan:

    2011-07-11 16:48:58, Info                  CSI    000002f9 [SR] Cannot repair member file [l:22{11}]"autochk.exe" of Microsoft-Windows-Autochk, Version = 6.1.7601.17514, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-07-11 16:48:58, Info                  CSI    000002fa [SR] This component was referenced by [l:202{101}]"Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7601.17514.WindowsFoundationDelivery"
    2011-07-11 16:48:58, Info                  CSI    000002fd [SR] Could not reproject corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:22{11}]"autochk.exe"; source file in store is also corrupted
    2011-07-11 16:48:59, Info                  CSI    000002ff [SR] Cannot repair member file [l:24{12}]"sorttbls.nlp" of mscorlib, Version = 6.1.7601.17587, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:b77a5c561934e089}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-07-11 16:48:59, Info                  CSI    00000300 [SR] This component was referenced by [l:156{78}]"Package_3_for_KB2518869~31bf3856ad364e35~amd64~~6.1.1.0.2518869-34_neutral_GDR"

     

    I don't really know what else to try or where else to look for help.  I'd greatly appreciate any advice.

    Monday, July 11, 2011 10:53 PM

Answers

All replies