none
Credential Spec Support? RRS feed

  • Question

  • My team has been trying to get docker containers working through 'docker service' and 'docker stack' for the last month or two. Is there any word on when those will have credentialspec fully supported (and not ignored by dockerAPI) ?

    I know 17.06-dev was released recently, but I'd also like to know when that will be officially released to windows server. (I'm not sure if those are different questions or not).

    Thanks,

    -whatiwonder


    Monday, June 19, 2017 2:49 PM

All replies

  • I would like to have this feature as well. From the point of Windows user we need better Windows integration on all provided services (gMSA on Docker and Docker Swarm as well; i.e. on Docker Services and Docker Stack should support it).

    I hope 17.06 ee will provide these features but as there is no official roadmap we can just guess.


    • Edited by Jakub Vanak Tuesday, June 20, 2017 9:38 AM Wrong formating
    Tuesday, June 20, 2017 9:37 AM
  • I talked to a guy at Docker (https://github.com/moby/moby/issues/32053). Docker stack/compose (with credential-spec support) will be released with 17.06 (all versions). It's currently in Edge for CE and will hopefully be released to Stable soon. After that, the guy I talked to said it should be 3-5 weeks or so that 17.06 will be released to EE.

    You can get the CE Edge version installer from the Docker downloads page, or you can get the binaries here: https://download.docker.com/win/static/test/x86_64/

    You can also get the nightly binary builds here: https://master.dockerproject.org/

    I've already tested the CE Edge version, and the credential-spec feature works great :)

    I'm assuming once 17.06 is released for EE the DockerMsftProvider will automatically use the new version (if you run the install cmdlet with a -Force or -Update it will install the new version), but since we haven't heard anything yet from this forum, I can't say for sure.

    Friday, June 23, 2017 5:37 PM