none
VS2008SP1,C# Invoke C++,the .exe does not run with external manifest RRS feed

  • Question

  • If Using embedd manifest,CSharpClient_42.exe run ok.

    If using external manifest, build it ok, but the .exe file does not run.

    run CSharpClient_42.exe, the results pop-up dialog box, showing that the application is configured incorrectly, the application failed to start, re-installing the application may be to correct the problem.

    If deleted "<assemblyIdentity name="ManagedClassWrapper.dll" version="" />" in CSharpClient_42.exe.manifest, then CSharpClient_42.exe run ok.

    CSharpClient_42.exe.manifest(which VS2008 auto generat):

    <?xml version="1.0" encoding="utf-8"?>
    <assembly xsi:schemaLocation="urn:schemas-microsoft-com:asm.v1 assembly.adaptive.xsd" manifestVersion="1.0" xmlns:asmv1="urn:schemas-microsoft-com:asm.v1" xmlns:asmv2="urn:schemas-microsoft-com:asm.v2" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#" xmlns:co.v1="urn:schemas-microsoft-com:clickonce.v1" xmlns="urn:schemas-microsoft-com:asm.v1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <assemblyIdentity name="CSharpClient_42.exe" version="1.0.0.0" processorArchitecture="x86" type="win32" />
      <dependency>
        <dependentAssembly asmv2:dependencyType="preRequisite">
          <assemblyIdentity name="Microsoft.VC90.CRT" version="9.0.21022.8" publicKeyToken="1fc8b3b9a1e18e3b" processorArchitecture="x86" type="win32" />
        </dependentAssembly>
      </dependency>
      <dependency>
        <dependentAssembly asmv2:dependencyType="install" asmv2:codebase="ManagedClassWrapper.dll.manifest" asmv2:size="650">
          <assemblyIdentity name="ManagedClassWrapper.dll" version="" />   note: If deleted the line, CSharpClient_42.exe run ok.
          <hash xmlns="urn:schemas-microsoft-com:asm.v2">
            <dsig:Transforms>
              <dsig:Transform Algorithm="urn:schemas-microsoft-com:HashTransforms.Identity" />
            </dsig:Transforms>
            <dsig:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1" />
            <dsig:DigestValue>fe0WS21Bx0HaRyTis40iLDlHrpw=</dsig:DigestValue>
          </hash>
        </dependentAssembly>
      </dependency>
    </assembly>

    Could you please help me? Thanks

    Download the source code packet:
    https://mega.co.nz/#!scECxIJa!8865SnjOCLQk69-B6WH5WxrRQ1o38-uA3CoWWb685TY

    Thursday, January 29, 2015 11:05 PM

All replies

  • Hello,

    Do you have a try to run the project with the administator? As far as I know the external manifist needs a aministator permission.

    And please also have a check this blog to find the reason why the external manifist is ignored:

    http://csi-windows.com/blog/all/27-csi-news-general/245-find-out-why-your-external-manifest-is-being-ignored

    Regards.

    Friday, January 30, 2015 8:58 AM
  • I run the project with the administator, it dose not run too.

    I think this is not a permissions problem,because if deleted the line of "<assemblyIdentity name="ManagedClassWrapper.dll" version="" />"  in CSharpClient_42.exe.manifest, then CSharpClient_42.exe run ok.


    Friday, January 30, 2015 9:36 AM
  • Hello LiulinkshiA,

    For this issue, i am trying to involve someone experienced to help look into it, it may take some time, as soon as we get any result, we will post back to this thread.

    Thanks for your understand and support.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 2, 2015 9:43 AM
    Moderator
  • The problem which is encountered, when I use a PC usb port to PC usb port (USB to USB) high-speed transparent transmission API Based on the USB(see: http://blog.csdn.net/zzkjliu/article/details/12838383)

    a long time is still not resolved in the Microsoft community,it seems only with embedded  manifest.
    Sunday, May 10, 2015 5:26 AM